WordPress.org

Support

Support » How-To and Troubleshooting » Switching from Visual mode to Code and back looses paragraph breaks

Switching from Visual mode to Code and back looses paragraph breaks

  • I’ve posted my blog entry with ecto (Mac version), then manually changed its type to page in phpMyAdmin page (MySQL database). Looks ok in my blog page (http://www.macpasaule.lv/?p=247). It uses standard paragraph marks <p>…</p>. But when I open it in Manage > Pages > Edit > Visual, switch to Code and back to Visual, all paragraph marks/breaks are lost! Actually they are already lost when I switch to Code. Why does editor can’t read properly code from MySQL database?! I’m confused…
    And it seems that I can’t set editor to use Code mode by default.

    I use Safari 3.0.4 web browser, Mac OS X 10.4.11 “Tiger”, and WP 2.3.1.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The Visual (aka wysiwyg) is NOT for using your own html code. And regardless of swtiching back and forth… if it is ON – it will always screw up your code. Period.
    Wnat your code – you turn OFF the Visual for good.
    admin > Users > Your profile.

    I am surprised that Visual removes <p> code! That’s the most basic code!
    Thanks for the tip how to turn this mode off. I just think that developers should pay much bigger attention to code preservation. <p> is even more important than <b> or <u> which get preserved…

    The visual gizmo is not really for those that know and want to use their own code. That’s for code illiterates… 🙂

    The basic html editor (when the visul is killed) preserves exactly your code. At least, it never messed up mine.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Switching from Visual mode to Code and back looses paragraph breaks’ is closed to new replies.