Switching Domains - Endless Loop (9 posts)

  1. iainbryden
    Posted 6 years ago #

    I followed the directions

    for moving my blog from http://www.websiteA.com/wordpress to http://www.websiteB.com.

    - I copied all files from A to B.
    - Saved/imported wordpress data from A to B
    - Changed wp-config.php to use the new mysql un/pw

    I can see all my pages and blogs in the management areas, but when I go to http://www.websiteB.com Firefox gives me "Redirect Loop" error. I can't see any pages without getting this error. Any idea what's wrong?

  2. moshu
    Posted 6 years ago #

    Did you change the site_url and home values in the database to reflect domainB instead of domainA/subdir?

  3. iainbryden
    Posted 6 years ago #

    moshu, yes I did. Both site_url and home are set to "www.websiteB.com"

  4. moshu
    Posted 6 years ago #

    Next step: did you try to put the relevant part of your error message in the Search box? Chances are you are not the first with that error...

  5. iainbryden
    Posted 6 years ago #

    Yes, I have been trying to fix this for several hours. There are some posts about redirect loops happening with the admin pages, with permalinks turned on, with an .htaccess file, but none what showed my issue, except for the fact that I was using an older version of WP, but I've recently updated.

  6. iainbryden
    Posted 6 years ago #

    I found a posting with a link to

    . It's a plug-in called Disable Canonical URL Redirection. It seems to work. But it seems strange that I need a plug-in to fix this problem.

    Any other ideas?

  7. Samuel B
    Posted 6 years ago #

  8. iainbryden
    Posted 6 years ago #

    Thanks samboll, but no good. I looked at that before. A forum moderator moved the part of the thread that contained the actual solution to another location, which is now a broken link.

    from the thread:

    This is the entire wp-settings.php file:

    Removed by moderator. Post only your changes, or use http://wordpress.pastebin.ca for large files.
    The modification is on line 89.

    Also, 'Disable Canonical URL Redirection' causes errors in my admin pages making it so I can't do certain things, like sign out or make certain updates. I get errors like these:

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/i/a/i/foo/html/wp-content/plugins/disable-canonical-redirects/disable-canonical-redirects.php:12) in /home/content/i/a/i/foo/html/wp-login.php on line 267

    wp-login.php Line 267 is:

    header('Content-Type: '.get_bloginfo('html_type').'; charset='.get_bloginfo('charset'));

  9. packetloss
    Posted 6 years ago #

    I had same issue after moving from wordpress/ to root. disable-canonical-redirect worked for me.

Topic Closed

This topic has been closed to new replies.

About this Topic