Support » Networking WordPress » Switched URL on Multisite, Won’t Connect Database Unless Multisite False

  • I had to move a multi-site installation and it’s not gone well.

    The site will not connect the database unless I change the config file to:

    define( ‘WP_ALLOW_MULTISITE’, false);
    define(‘MULTISITE’, false);
    define(‘SUBDOMAIN_INSTALL’, false);

    This would be fine, except I did not have the foresight to set up an admin user for each site individually. My main admin password does not work.

    I’ve tried a password reset, and emergency.php file with no success.

    Does anyone have any ideas for me?

Viewing 2 replies - 1 through 2 (of 2 total)
  • > I had to move a multi-site installation and it’s not gone well.

    Not enough information, how did you move it? Did you change anything in the move?

    I copy my production WP systems to a dev, test, and stage system. Exact copy with no alterations… I have no problems.

    If you change hostnames, then you have to change your database and your wp-config.php

    Thanks for replying, sorry about my slow response.

    I exported the database via my SQL, and pulled all of the php files for the site off of my hosting using FTP.

    I then was forced to (by my client) upload the php files to root/public_html using an SSH connection. The database went elsewhere but was only able to be uploaded using command line. There were problems with permissions and I ended up bringing in my husband who is a software developer to assist me using sudo to get the database in. To be clear, command line and sudo are beyond me. I would prefer to be in a CPanel.

    During this process we had a lot of issues with permissions etc. I cant see the SQL to confirm that all lines came across.

    I did of course update the .htaccess and config.php as per WordPress’s instructions.

    I can get the site up if I change Multisite answers to false, it connects to the database, but I can’t access the site as the Admin password is for multi-site.

    Any thoughts on where I could go with this next? I really appreciate any help or suggestions.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Switched URL on Multisite, Won’t Connect Database Unless Multisite False’ is closed to new replies.