Media Vault
[resolved] Switched to WP Multisite and get warning message: (7 posts)

  1. wwn2013
    Posted 1 year ago #

    Media Vault was working on my singlesite with WP and when I switched to multisite with WP this is the error, see below and attached, I get when trying to activate Media Vault. I've already followed the step to add the code to .htaccess. Double checked the file for mv-extra-activation-steps.php with your Media Activation Helper.

    Error: Warning: _() expects exactly 1 parameter, 2 given in /home1/wwn2013/public_html/wp-content/plugins/media-vault/mv-extra-activation-steps.php on line 240

    Here is what is on the page:
    1. Add the following to your .htaccess file in /home1/wwn2013/public_html/ in the WordPress rewrite block (the WordPress block usually starts with # BEGIN WordPress and ends with # END WordPress), just below the line reading RewriteRule ^index\.php$ - [L]

    Text Box with Rewrite Rules

    2. Once you have completed the above steps, press the "Enable Media Vault" button below.

    Warning: _() expects exactly 1 parameter, 2 given in /home1/wwn2013/public_html/wp-content/plugins/media-vault/mv-extra-activation-steps.php on line 240


  2. Max GJ Panas
    Plugin Author

    Posted 1 year ago #

    Hey wwn thanks for the info! Don't know how that did not trigger in my tests.. it was a typo I made with the translatable text of the "Enable Media Vault" button on the page.

    I pushed an update that should fix the issue, thanks for pointing it out!

    Let me know if it is working now, or if there is anything else!

  3. wwn2013
    Posted 1 year ago #

    Hey Max,
    Thanks for the quick response. I'll let you know when it's working.

    Currently working on fixing the WP MU configuration. Having a challenge with the .htaccess file. Once corrected, I'll update Media Vault and let you know the results!

    Thanks again!

  4. wwn2013
    Posted 1 year ago #

    Hi Max,
    I still haven't changed over to the multisite. Challenges with the http://www.mydomain./blog link. I think we figured it out.

    With regards to the file vault. I have audio files set to be accessed by logged in users only, however, when testing on a different computer and not logged in, the file link is accessible. This is a concern whether I'm in single-site or multisite mode.

    These files are marked as SSL too, if I need to remove them from SSL fine, I just want access to the files blocked to non-logged in users.

    any assistance?


  5. wwn2013
    Posted 1 year ago #

    Hi Max,
    Apologies, the files are protected. It think the server needed to update.

    The only thing is that when a non-logged in user tries to access the file a 404 error comes up instead of the designated replacement image image.

    Apologies also if this should be in a new ticket, I'm new to all things wordpress.


  6. wwn2013
    Posted 1 year ago #

    Again. Please ignore my above post. I got this situated.

  7. Max GJ Panas
    Plugin Author

    Posted 1 year ago #

    Hey, no worries wwn, glad everything is working and thanks again for posting the bug u found!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Media Vault
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic