Support » Localhost Installs » Switched servers, fixed wp-config.php, and posts/data have disappeared

  • Ok I’ll try and break this down as simply as possible.

    1. I created a site for my client on my own site/server
    2. Once the site was done and approved, I transferred all files to the client’s site/server
    3. I fixed all links so site was running independently on client’s site
    4. I removed all files from my site
    5. *Months pass without incident*
    6. I removed old WordPress installs on my server that are no longer in use, one being the one for this client
    7. Their site goes down, Database issue in wp-config.php
    8. Fixed DB_NAME, DB_USER, _DB_HOST to match client’s MySQL DB
    9. The site has “reset” to the blank theme, as if it was just installed, even though I can see all my images and other files on the FTP.
    10. Lay down, cry… a lot. Help please.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi UniikMedia
    The same thing happened to me. Did you find a solution?

    It seems that I did not upload the database XML file and the new site was just linking back to the old database… and when I uninstalled WordPress from my site, the new site had no database to load from.

    Best part about it, I can’t find the .xml backup. You know when everything you read about WordPress says “BACK UP YOUR SITE ALL THE TIME!!!!!!”… yeah, listen to that.

    Yes you got it, backups are crucial!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Switched servers, fixed wp-config.php, and posts/data have disappeared’ is closed to new replies.