Support » Plugins and Hacks » svn.wp-plugins.org issue with “non utf8 characters”

svn.wp-plugins.org issue with “non utf8 characters”

  • Hi all,

    I’m trying to commit a new beta version of Yet Another Related Posts Plugin to svn.wp-plugins.org . I already committed all the changes to trunk and indeed the changes are reflected in the “development version”. However, after

    svn cp trunk tags/3.0b7
    svn ci -m 'tagging 3.0b7'

    I get the error:

    Transmitting file data ..........................svn: Commit failed (details follow):
    svn: 'pre-commit' hook failed with error output:
    yet-another-related-posts-plugin/tags/3.0b7/ contains non utf8 characters

    Does anyone know what this error is? How can I fix it? I’ve tried from a different machine, adding the files one by one… no dice. And it all worked fine in trunk! :'(

Viewing 15 replies - 1 through 15 (of 26 total)
  • Hello, i get the same error when i try to add another file to my repository… i do this:
    1. svn add trunk/gpl3.txt
    2. svn ci -m “Test it”
    3. svn says:
    Adding trunk/gpl3.txt
    Transmitting file data .svn: Commit failed (details follow):
    svn: MERGE request failed on ‘/occupancyplan/trunk’
    svn: ‘pre-commit’ hook failed with error output:
    occupancyplan/trunk/gpl3.txt contains non utf8 characters

    what can I do or what am i doing wrong? the gpl3.txt contains only utf8 characters. I have also tested with a 0 byte file, but the error is the same. I have also tested with my pod files… all the same error msg :-/

    Justin Tadlock


    WordPress God

    There must be something going on right now. I’ve been experiencing the same problems described above for the last couple of hours.

    The problem seems to be when I try to commit a new file. I can make changes to files that already exist in the repository, but I can’t commit new ones.

    Error message:

    Commit failed (details follow):
    'pre-commit' hook failed with error output:
    widgets-reloaded/trunk/test.php contains non utf8 characters

    Ditto. Same here.

    Since more than one hour same here (from Europe) when adding a new tag folder…. it seem to be a svn server error…. hope the admin will repear it soooooon

    Whew! I’m glad (I guess) that I wasn’t going crazy… I did get a commit to work exactly two hours ago, but then it started failing right after that.

    Hope this gets resolved soon!

    Hi all,

    Same problem for me. I created a new entry in the SVN for uploading a plugin (WP-MoniTee) and I can’t commit any file.

    I tried to convert all files in ANSI then in utf-8 but the error still here…

    LOL yep, same issue here

    Good to know, I also was getting crazy while trying to submit a new version. We’ll probably just have to sit it out, then.

    Same here.

    Oh crap, that’s why everyone goes nuts after downloading my “incomplete” upgrade.

    Moderator Barry


    Can you guys try again? It should be working now.

    I think it went through this time.

    OK – 19:25 – Europe – Paris Time : all is working again – congratulations !

    All good.

    How long does it take for a new version to be updated in the main plugin directory? I committed a new version about 40 minutes ago, but it’s still not updated in the directory. Any ideas?

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘svn.wp-plugins.org issue with “non utf8 characters”’ is closed to new replies.