[resolved] SVN Commit Problem [403 forbidden] (7 posts)

  1. Osama Shabrez
    Posted 4 years ago #


    I recently developed a plugin of mine and requested wordpress.org to add it into the plugins repository, after a few hours of submission I got a confirmation email from wordpress that my plugin is approved and I can submit it to the SVN repository through the same usr/psw of forums.

    I performed each and every step said in the help file and now its around two days, I am unable to update my repository space, the error I got on commit is:

    Commit Failed: Server send unexpected return value (403 forbidden) in response to CHECKOUT request ...

  2. Can you try changing your passwords on the forums, and see if that kicks it into working?

  3. Osama Shabrez
    Posted 4 years ago #

    Ipstenu thanks for your reply, but I have already tried changing my password and password reset as well.

    I write to the plugin support but they just replied one of my emails and after that it looks like there isn't any support for us developers.

  4. There kinda sorta is :)

    Are you using any capital letters in your username? It's case sensitive, and I remember this being a problem before.

  5. Osama Shabrez
    Posted 4 years ago #

    No, but to be very honest I don't remember what exactly I set my username as while registering for this forum. I have already tried with all caps, first word capital and all other sequences. None of them actually worked.

    I searched a lot on different forums and a few people said this happens when the profile is not actually activated for the SVN.

    It would be really great if you can check my username and provide me the exact as you are the mod here or I have to create another profile and submit my plugin once again - Will this work?

    I'll be waiting for your reply.

  6. Protip - it's osamashabrez (ALL lowercase)

    You can tell by going to your profile - http://wordpress.org/support/profile/osamashabrez

    Don't need to be a mod for that one!

  7. Osama Shabrez
    Posted 4 years ago #

    OK I have uploaded my plugin successfully via another plugin submission request, I guess culprit was the bad url structure which I didn't care about as I was aware how wp will gonna treat with the plugin's name.

    Problem solved anyways, and thanks Ipstenu for you kind response and time.


Topic Closed

This topic has been closed to new replies.

About this Topic