Support » Developing with WordPress » SVN commit fails due to password containing a special symbol

  • Hello. I maintain a plugin in the WordPress plugin repo. I have made an edit to the plugin on my local computer, and am now trying to commit this to the WordPress plugin repo, using this SVN command that I’ve used many times in the past:

    svn ci -m 'Confirm compatibility with WordPress v5.6'

    But it is failing with

    svn: E215004: Authentication failed and interactive prompting is disabled; see the --force-interactive option
    svn: E215004: Commit failed (details follow):
    svn: E215004: No more credentials or we tried too many times.
    Authentication failed

    I then added my username/password to the command, like so (that is not my actual password).

    svn ci -m 'Confirm compatibility with WordPress v5.6' --username xxxxxx --password P@xxxxxxxxxx!

    But this command is failing, and I believe the reason is because my password has an @ in it, which seems to instruct the command line to separate the command into two commands at that point. How can I resolve this issue, other than changing my password?
    ___
    Full output below

    $ svn ci -m 'Confirm compatibility with WordPress v5.6' --username carlgross --password xxx@xxxxxx
    
    [1] 846
    bash: xxxxxx: command not found
    
    $ svn: E215004: Authentication failed and interactive prompting is disabled; see the --force-interactive option
    svn: E215004: Commit failed (details follow):
    svn: E215004: No more credentials or we tried too many times.
    Authentication failed

    [1]+ Exit 1 svn ci -m ‘Confirm compatibility with WordPress v5.6’ –username carlgross –password xxxx

Viewing 4 replies - 1 through 4 (of 4 total)
  • Moderator Steve Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Rep

    1. You published your password publicly. CHANGE IT IMMEDIATELY.

    2. Contact plugins@wordpress.org or post in the #pluginreview channel on Slack.

    Thread Starter Carl Gross

    (@carlgross)

    Sorry, I should have mentioned that is not my actual password. I’ll note that in my post.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Plugin Review Team Rep

    Well I wish I saw that reply before I force-reset your password.

    Please just X it out next time. We have an abundance of caution here with passwords and security.

    (Your password for SVN is your WP.org password, same thing)

    But this command is failing, and I believe the reason is because my password has an @ in it, which seems to instruct the command line to separate the command into two commands at that point. How can I resolve this issue, other than changing my password?

    Try putting quotes around it next time, but be aware SVN is really stupid and doesn’t like special characters equally. Yes, we know that’s a problem.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Don’t include the password on the command line, simply type it in directly in interactive mode instead.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘SVN commit fails due to password containing a special symbol’ is closed to new replies.