Support » Everything else WordPress » SVN Commit Failed for Plugin

  • Resolved Scott DeLuzio

    (@scottdeluzio)


    I have been trying to update a plugin, and can’t seem to get the commit to get through.
    I am using Tortise SVN and it seems to hang on the “Sending Content” action, then it gives the following errors:

    Commit failed (details follow):
    Error running context: An existing connection was forcibly closed by the remote host.
    Additional errors:
    Error running context: No connection could be made because the target machine actively refused it.

    I have made updates to this (and other plugins) in the past with no problem using the same method I am using now.
    I tried to checkout the plugin again using https instead of http in the plugin URL and then re-commit the changes, which didn’t help.
    I tried re-entering my WordPress.org username/password.
    Nothing seemed to work.
    When I go to update the plugin through one of my sites that has it installed, the plugin seems to update to the correct (updated) version. I can’t quite figure out if this error is a false error or if there’s something actually wrong?

Viewing 5 replies - 1 through 5 (of 5 total)
  • I was having this problem all day yesterday and this morning. What seems to have worked for me is updating my version of Tortoise SVN. It seems I wasn’t using the latest version. Could be a coincidence.

    Out of curiosity, is the last update value for your plugin stuck at 1 minute? Mine was at that value all day yesterday.

    Thread Starter Scott DeLuzio

    (@scottdeluzio)

    Thanks for pointing out the update Marios! I didn’t realize that I was behind on the updates, but that seemed to make it work for me.
    I don’t recall where it got stuck, but the strange thing for me was that it stayed in the sending content action for quite some time before it finally displayed the message I quoted above. Once it sent that message, it said that the commit was complete. Since the committed files made it to the plugin directory, I’m thinking that the error was just in Tortise SVN and not anywhere in WordPress.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Our servers run svn 1.7. Older versions of clients may not work. Update the client.

    Thread Starter Scott DeLuzio

    (@scottdeluzio)

    Yes that seemed to be the issue. I was able to commit changes to the plugin yesterday without any problems after updating.
    Everything was working fine last week on the older version, but I guess something somewhere along the line caused it to stop working. Regardless of what, the update made it work.

    Hi, Scott@
    Please solve this problem—-

    Commit failed (details follow):
    POST of ‘/!svn/me’: 403 Forbidden (https://plugins.svn.wordpress.org)

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘SVN Commit Failed for Plugin’ is closed to new replies.