Support » Plugin: SVG Support » SVG not uploading anymore

  • Resolved ignaziolaci

    (@ignaziolaci)


    After the last wordpress update I’m unable to uplaod SVGs 🙁 I keep on getting this error “Sorry, this file type is not permitted for security reasons”

    Any suggestions?

    Thank you!

Viewing 14 replies - 1 through 14 (of 14 total)
  • here the same! after the 4.7.1 WP update i’m not able anymore to upload svg.

    I found this temporary fix, just add to your wp-config.php the following:

    define(‘ALLOW_UNFILTERED_UPLOADS’, true);

    but I think this is just temporary because it allows every file type.

    any suggestion from the developer?

    thank you in advance!

    Thank you for this temporary fix ! You save my day !

    Hi everybody,
    I speak french and do not understand all the topics in this discussion.
    Is there now a solution for uploaded SVG files?
    It became very urgent for me.
    Thanks for reply or solution.

    I forgot one thing:

    you need to keep active the SVG Support plugin other than adding the following code to you wp-config.php file:
    define(‘ALLOW_UNFILTERED_UPLOADS’, true);

    I’m glad that this solved some of your isseus.

    Subfighter3, thanks it works. Merci beaucoup!

    I’m having the same issue… kept thinking I was doing something wrong! I’ll try the suggestion above.

    Plugin Author Benbodhi

    (@benbodhi)

    Hi everyone,

    WordPress changed the way it handles uploads in 4.7.1 and in effect, some file types wouldn’t upload anymore. There is 2 issues in the core trac that will provide a fix in 4.7.2.

    In the meantime, I have updated my plugin to take care of it (2.2.4).
    Thank you for your patience and support!

    THANK YOU for such a quick fix! I was able to upload my SVG, but it is giving an error at the next stage: “There has been an error cropping your image.”

    There’s no option to bypass the cropping stage. We only have one choice — to click the ‘crop’ button.

    Plugin Author Benbodhi

    (@benbodhi)

    Hi @butterflyherder,

    That is a separate issue to do with your theme. Please follow the link in this support post: https://wordpress.org/support/topic/svg-not-displaying-in-customizer/

    OH! Good to know, thank you! This is the first time I’ve tried using SVG… lots to learn! 🙂

    Plugin Author Benbodhi

    (@benbodhi)

    @butterflyherder, no problem. Good luck and have fun 🙂

    • This reply was modified 1 year, 5 months ago by  Benbodhi. Reason: spelling

    I wonder if there is no security issue on this hack? Thanks btw.

    Plugin Author Benbodhi

    (@benbodhi)

    Hi @annalyn,

    This is not how it was handled in my plugin, it was a short term solution while we were all working on it.
    My plugin has a nicer solution and WP 4.7.2 was just released, so I will be testing and only running this workaround code in WP versions that need it. It should be fixed in the latest WP release though, which means it would only run in 4.7.1… and again, it is not the allow unfiltered uploads solution.

    Thanks for your interest in my plugin.

    Hi @benbodhi, it didn’t work for me, and then I realized that this thread is for your SVG plugin, I was working on SVG function on my theme, lol! I end up saving a png file for my icons. Thanks anyways.

    Keep on doing a great job!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘SVG not uploading anymore’ is closed to new replies.