Support » Plugin: Scalable Vector Graphics (SVG) » SVG in image gallery is not working

Viewing 5 replies - 16 through 20 (of 20 total)
  • Plugin Author Sterling Hamilton

    (@sterlo)

    Plugin Author Sterling Hamilton

    (@sterlo)

    Alrighty — I have created a patch for that ticket — I have created a feature that fixes this problem once they implement that patch.

    Plugin Author Sterling Hamilton

    (@sterlo)

    Code your Theme developer needs to address specifically:

    function expositio_image_tag($thumbnail_id, $size = 'post-thumbnail') {
            $meta = wp_get_attachment_metadata($thumbnail_id);
            if ($meta === false || $meta === '') {
                    return sprintf(
                            '<img src="%s" width="%s" height="%s" alt="" />',
                            wpShower::defaultImage(),
                            wpShower::$default_image_width,
                            wpShower::$default_image_height
                    );
            }
    
            $src = wp_get_attachment_image_src($thumbnail_id, $size);
            $size_available = isset($meta['sizes'][$size]);
            return sprintf(
                    '<img src="%s" width="%s" height="%s" alt="" />',
                    $src[0],
                    $size_available ? $meta['sizes'][$size]['width'] : $meta['width'],
                    $size_available ? $meta['sizes'][$size]['height'] : $meta['height']
            );
    }

    Ok, thanks a lot for your notes Sterling.
    I’m trying to contact the developers to inform/ask about the issue.
    I’ll keep you informed.

    🙂

    Plugin Author Sterling Hamilton

    (@sterlo)

    I am assuming we are good here. Hope things worked out!

Viewing 5 replies - 16 through 20 (of 20 total)
  • The topic ‘SVG in image gallery is not working’ is closed to new replies.