Support » Plugin: iThemes Security (formerly Better WP Security) » SVG files forbidden 403 errors

  • Hi,

    When I don’t have Ithemes security installed, I can perfectly use SVG files. I have the “safe SVG” plugin which sanitizes SVG files so they are not a security risc.

    However, when I enable Ithemes, it gives a “svg 403 forbidden error”, and the site runs very very slow due to this continuous and unnecessary blocking.

    Backend log: PHP Warning: file_get_contents(https://www.site.info/wp-content/uploads/2018/09/decor-infobox-vase.svg): failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden\r\n in /home/site.info/wp-content/plugins/woodmart-core/post-types.php on line 628\n, referer: https://www.site.info//wp-admin/post.php?post=1991&action=edit

    How can I fix this, without disabling Ithemes ?

    thanks

Viewing 2 replies - 1 through 2 (of 2 total)
  • MATT M

    (@beardedginger)

    Hi,

    I am sorry to hear you are running into this! Will you please try disabling the following features to see if it helps?

    Hackrepair Blacklist Feature
    (Security> Settings> Banned Users)

    Filter Long URL Strings
    (Security> Settings> System Tweaks)

    Filter Suspicious Query Strings in the URL
    (Security> Settings> System Tweaks)

    Filter Non-English Characters
    (Security> Settings> System Tweaks)

    You may also try enabling XML-RPC and allowing Full Access to the REST API.
    (Security> Settings> WordPress Tweaks> XML-RPC)

    Thanks,
    Matt
    iThemes.com

    Hi,

    Disabling all those essentials kinda defeats the whole purpose of a security plugin and firewall ?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘SVG files forbidden 403 errors’ is closed to new replies.