Support » Plugin: SurveyPress » Surveypress fails to create new users

  • Resolved mrexcalibur

    (@mrexcalibur)


    suddenly surveypress fails to create users!

    it says it cant find create_survey in lime_user….

    is it the wordpress 4 or the new limesurvey…? what should i downgrage? (its risky, i have running surveys)

    maybe you can fix surveypress, it seems the database has changed ??
    ————-

    after clicking on the url in mail… it says:

    Warning: Missing argument 2 for wpdb::prepare(), called in /var/customers/webs/excalibur/wordpress/wp-content/plugins/surveypress/survey-press.php on line 420 and defined in /var/customers/webs/excalibur/wordpress/wp-includes/wp-db.php on line 1154 Call Stack: 0.0020 1160344 1. {main}() /var/customers/webs/excalibur/wordpress/wp-login.php:0 0.2262 40334840 2. wp_signon() /var/customers/webs/excalibur/wordpress/wp-login.php:766 0.2262 40336608 3. do_action_ref_array() /var/customers/webs/excalibur/wordpress/wp-includes/user.php:54 0.2263 40338152 4. call_user_func_array() /var/customers/webs/excalibur/wordpress/wp-includes/plugin.php:580 0.2263 40338208 5. Bridge_WP_LS::an_check_user_authentication() /var/customers/webs/excalibur/wordpress/wp-includes/plugin.php:580 0.2410 40452648 6. Bridge_WP_LS::an_insert_into_ls() /var/customers/webs/excalibur/wordpress/wp-content/plugins/surveypress/survey-press.php:661 0.2772 40668616 7. wpdb->prepare() /var/customers/webs/excalibur/wordpress/wp-content/plugins/surveypress/survey-press.php:420
    WordPress database error: [Unknown column ‘create_survey’ in ‘field list’]
    INSERT INTO lime_users (users_name,password,full_name,parent_id,lang,email,create_survey,create_user,delete_user,superadmin,configurator,manage_template,manage_label) VALUES (‘demo1′,’1a9f895f76b331a9208570c33bc34aafdc19bd75e9a134d58cbccce0877ed9a8′,’ ‘,1,’auto’,’demo1@dontsendmespam.de’,1,0,0,0,0,0,0)

    unable to update records in ls table with given credentials!

    https://wordpress.org/plugins/surveypress/

Viewing 2 replies - 1 through 2 (of 2 total)
  • skyonfire

    (@skyonfire)

    Installed surveypress with limesurvey 1.92 and WP 4.0
    The “online surveys now”-page (for non-admin users) works but also shows this error:
    … /www/htdocs/XXXX/wp-includes/wp-db.php on line 1154
    That’s all the errors I see at the moment. Were you able to resolve any or have an update of any kind?

    mrexcalibur

    (@mrexcalibur)

    I have WP 4 and limesurvey Version 2.05+ Build 140520

    when a new user signs up in WordPress he gets his mail… but when he clicks the link in the mail/ signs up for first time… he gets the error (like above)

    –> i have not fixed it yet, i waited for the surveypress dev. to make an update, but i got no reply yet.

    what i do not understand is, the error itself:

    it cant find the column create_survey? to set this permission…. HOW DOES THE PERMISSION system work in Ls 2.xx+ ? i think i just have to edit some small parts in code / change some to new sql variables… (i think they moved sth.)

    but i do not know what they changed / where it moved.

    —-

    to reproduce my error, i have set permission in surveypress to create_survey ( check the 1.0.0.0.0.0 stuff at the end)

    maybe it may work when permissions are not set, but this setting is important, i dont want the users to edit my survey theme (remove my website name of the theme) because thats advertising for new potential users that participate in a survey.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Surveypress fails to create new users’ is closed to new replies.