Support » Plugin: Advanced Sidebar Menu » Surprised at how easy this was to set up

  • phantasmix

    (@phantasmix)


    Does the job well. Super easy to configure. Thanks!

    P.S. When “include parent page” option is checked, the children don’t show up. Not sure if it’s a theme-related glitch. The plugin does what I need otherwise.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Mat Lipe

    (@mat-lipe)

    Hi phantasmix,

    Please post a link to where the issue is occurring along with the version of WP and the version of the plugin you are using.

    So far I have been unable to recreate the issue so it is most likely a theme or other plugin issue, but the above information may help.

    Thanks

    phantasmix

    (@phantasmix)

    Hi Mat,
    no other plugins are activated at this time, it’s a fresh install with only Advanced Sidebar Menu in place 🙂

    The them I’m using to setup the site skeleton is Clean Retina Free. I won’t end up using it for development though so it doesn’t make sense to troubleshoot it.

    The settings I used are:
    Check “Include parent page”
    Check “Always display Child pages”
    Levels to Display 2

    Everything else unchecked. And what it does is just show the parent page in the side bar, no children.

    Plugin Author Mat Lipe

    (@mat-lipe)

    Hi phantasmix,

    What does you page list screen look like. Could you post a screenshot?

    phantasmix

    (@phantasmix)

    They’re all nested like this, up to 4 levels

    PIC

    Plugin Author Mat Lipe

    (@mat-lipe)

    Can you send a link to one of these pages so I can see the output?

    Thanks

    phantasmix

    (@phantasmix)

    Plugin Author Mat Lipe

    (@mat-lipe)

    Hi phantasmix,

    It looks like it is currently displaying the child pages only. Most likely because you unchecked the display parent page option to get the pages to show up again.

    Even without being able to see the parent links output I can see there is definitely something filtering the output of the menu. Sounds like the only thing you have running is the theme so it is most likely something there.

    You will see in the html of the output there are extra links inserted with the class ‘default-menu’. Those are not supposed to be there and are most likely from the same thing causing the issue.

    If you remove lines 614 through 615 in your theme’s style.css file which looks like this

    li.default-menu {
    	display: none;
    }

    you will see what I am talking about.

    Hope this helps!

    phantasmix

    (@phantasmix)

    Are you around? I waited and waited for you to check the page, but then went back to the settings I actually need 🙂 I can turn on the settings that don’t work for me – if you’re around!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Surprised at how easy this was to set up’ is closed to new replies.