Support » Plugin: Slider by Supsystic » SupsysticSlider_Slider_Twig_SupTwg_Attachment not found

  • Resolved gingerbread1

    (@gingerbread1)


    Hi,

    plugin caused critical error due to component not found. Can i check if there is any updating i should do?

    An error of type E_ERROR was caused in line 401 of the file /var/www/html/wp-content/plugins/slider-by-supsystic/src/SupsysticSlider/Slider/Module.php. Error message: Uncaught Error: Class ‘SupsysticSlider_Slider_Twig_SupTwg_Attachment’ not found in /var/www/html/wp-content/plugins/slider-by-supsystic/src/SupsysticSlider/Slider/Module.php:401 Stack trace: #0 /var/www/html/wp-includes/class-wp-hook.php(287): SupsysticSlider_Slider_Module->loadExtensions(”) #1 /var/www/html/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters(NULL, Array) #2 /var/www/html/wp-includes/plugin.php(478): WP_Hook->do_action(Array) #3 /var/www/html/wp-content/plugins/slider-by-supsystic/vendor/Rsc/Resolver.php(173): do_action(‘ss_after_module…’) #4 /var/www/html/wp-content/plugins/slider-by-supsystic/vendor/Rsc/Environment.php(243): Rsc_Resolver->init() #5 /var/www/html/wp-includes/class-wp-hook.php(287): Rsc_Environment->extend(”) #6 /var/www/html/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters(NULL, Array) #7 /var/www/html/wp-includes/plugin.php(478): WP_Hook->do_action(Array) #8 /var/www/html/wp-settings.php(403): do_action(‘plugins_loaded’) #9 /var/www/html/wp-config.php(8

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author supsystic

    (@supsysticcom)

    Due to numerous requests from customers and for compatibility with other plugins, it was decided to update the TWIG libraries.
    Unfortunately, older versions will not be compatible with newer ones. Therefore, to use the latest Free versions of the plugin, you must update the PRO version.

    Best regards,
    Ole

    Thread Starter gingerbread1

    (@gingerbread1)

    Are you saying that we need to upgrade to the paid version if we are using the free version?

    Plugin Author supsystic

    (@supsysticcom)

    Are you saying that we need to upgrade to the paid version if we are using the free version?

    That’s right. If you have the old PRO version installed, you will have a critical error.

    We do not have the PRO version installed but rather the latest free version and it causes fatal errors.

    By the sound of your reply you expect us to upgrade to PRO? That cannot be right.

    This is the error

    An error of type E_ERROR was caused in line 401 of the file /***/***/public_html/wp-content/plugins/slider-by-supsystic/src/SupsysticSlider/Slider/Module.php. Error message: Uncaught Error: Class ‘SupsysticSlider_Slider_Twig_SupTwg_Attachment’ not found in /***/***/public_html/wp-content/plugins/slider-by-supsystic/src/SupsysticSlider/Slider/Module.php:401

    Plugin Support Support Ole

    (@trsupsys)

    Your issue is talk about only one thing – you have an old version of Slider or our other plugin.
    Uninstall all of our plugins, reinstall to latest versions.

    I have the same output as the OP.

    I do have Photo Gallery by Supsystic Version 1.14.8 as well. That seems fine. BOTH are the latest versions.

    Slider by Supsystic is Version 1.7.50

    By uninstall do you mean Delete? Won’t I lose all the work we have done within this when I reinstall?

    Plugin Support Support Ole

    (@trsupsys)

    By uninstall do you mean Delete? Won’t I lose all the work we have done within this when I reinstall?

    Right.
    You won’t lose your data during re-installation.

    Best regards,
    Ole

    I have the same error with the free version of supsystic slider.
    I uninstalled gallery (also free version, 1.14.8) and slider (1.7.50) plugins and reinstalled both. But I get the same error again for the slider.

    • This reply was modified 1 year, 1 month ago by muxipups.

    I just noticed that I can’t activate both, slider AND gallery plugin. Only one of them. If I activate both then slider plugin causes a complete website crash. if only one of both is active they are both working.

    fronimitis

    (@fronimitis)

    What an awful move from supsystic, and what an indifferent reply. Suddenly they kill your site with a critical error and ask for money for paid version.

    This is how people can get rid of this plugin and have a working site again:
    Using an FTP client or your control panel’s file manager, navigate to ‘yourwordpresswebsite/wp-content/plugins’ directory and delete (remove) plugin by deleting its folder.

    Plugin Support Support Ole

    (@trsupsys)

    The main thing was done in our response – solution has been provided that has already been tested for more than 2000 customers.
    If you still get a Twig error, then you have activated the old version of any of our plugins. You need to remove it, just install the new version.

    muxipups

    (@muxipups)

    that’s not correct. I use (incl. latest wordpress version)

    Photo Gallery by Supsystic
    Version 1.14.8

    Responsive Slider by Supsystic
    Version 1.7.50

    when activating both supsystic plugins the website is crashing. When deactivating one of them the other plugin is working fine.

    Plugin Support Support Ole

    (@trsupsys)

    that’s not correct. I use (incl. latest wordpress version)

    https://puu.sh/G4x4N/1f676d6d71.png

    Please contact us through our
    internal support.
    We will help you to solve the problem.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘SupsysticSlider_Slider_Twig_SupTwg_Attachment not found’ is closed to new replies.