Support » Plugin: Z-URL Preview » Suppress Header

  • Resolved taobp

    (@taobp)


    I like how the header fills the title field if left blank but don’t want it in the post above the image as well.

    Suspect most users would want it in the title or in the post but not both?

    Possible to give the options of [ neither; both; title; or post ] in the settings?

    Thank you for this plug-in.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author StuartMillington

    (@stuartmillington)

    Hi,

    The option to suppress the header in the content was added 7 months ago:
    “V1.5.7 Added option to suppress header tag”

    Thank you but this does not resolve my issue. If you suppress the header it does not show up in either the title field or in the body. Is there a way to have it appear in the wordpress title field but not in the body of the post?

    Thanks again!

    Plugin Author StuartMillington

    (@stuartmillington)

    Hi,

    Sorry, it wasn’t meant to suppress the title field only the tag in the article body. I hadn’t notice that it did that. I’ll see if I can push a fixed version in the next couple of days.

    Plugin Author StuartMillington

    (@stuartmillington)

    Hi,

    Try v1.6.1 when it’s up. I just pushed it.

    This comes from a core issue in the original design. Short-ish version… the PHP does the CURL and returns a block of HTML to the J(ava)script. The J(ava)script then adds the content to the post.

    But… it parses the content to get the header to create the title from the h2 tag. So turning off the h2 tag meant there was no content to add to the title. Catch-22.

    I’ve had to add a display:none tag so that the J(ava)script has something to get the title from even when the h2 is disabled.

    Hopefully it won’t mess anything else up!

    Plugin Author StuartMillington

    (@stuartmillington)

    I don’t know why 1.6.1 isn’t live yet, it went up on SVN 4 days ago.

    Plugin Author StuartMillington

    (@stuartmillington)

    OK, 1.6.1 is finally up. May be 1.6.2 too.

    Not sure what happened.

    taobp

    (@taobp)

    Thank you for the update.
    Here are my settings…
    Link Label Source:
    Link Mode target=_blank
    Supress Header Tag Yes
    Supress Image No
    Supress Intro No
    Title as Link Text No
    Main Heading as Link No
    Main Image as Link No
    Button Location TinyMCE Row 1
    Parse Mode HTML Dom

    The header doesn’t show up in the body anymore. Unfortunately, the title field is left blank as well.

    If I “Supress Header Tag No” it shows up in both the body and the title.

    Just to restate: I would appreciate having the header in the title field but not in the body.

    • This reply was modified 2 years ago by  taobp.
    Plugin Author StuartMillington

    (@stuartmillington)

    Hi,

    With 1.6.1 and those settings it does populate the header if it’s blank.

    The chance is in the 1.6.1 code, but something is going on with SVN updates. Try removing and reinstalling the plugin.

    taobp

    (@taobp)

    Deactivated… Deleted… Reinstalled

    Still no title. Everything works as it should, image is retrieved, link to source site is displayed but title remains blank.

    • This reply was modified 2 years ago by  taobp.
    taobp

    (@taobp)

    Hang on, it’s working now. Fingers crossed.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Suppress Header’ is closed to new replies.