WordPress.org

Forums

myCRED
[resolved] Supported Shopping Carts produce an error in 1.3 (1 post)

  1. Gabriel
    Member
    Plugin Author

    Posted 1 year ago #

    Issue:
    After updating to myCRED 1.3, the myCRED payment gateway for each supported shopping cart produces an error message preventing settings from being saved.

    Resolution for WooCommerce users:
    Open the mycred-woocommerce.php file located in plugins/mycred/add-ons/gateway/carts/ folder and on line 17 change it from:

    add_action( 'plugins_loaded', 'mycred_init_wpecom_construct_gateway' );

    to

    add_action( 'after_setup_theme', 'mycred_init_wpecom_construct_gateway' );

    Resolution for MarketPress users:
    Open the mycred-marketpress.php file located in plugins/mycred/add-ons/gateway/carts/ folder and on line 9 change it from:

    add_action( 'plugins_loaded', 'mycred_init_marketpress_gateway', 5 );

    to

    add_action( 'after_setup_theme', 'mycred_init_marketpress_gateway' );

    For WP-E-Commerce users:
    Open the mycred-wpecommerce.php file located in plugins/mycred/add-ons/gateway/carts/ folder and on line 17 change it from:

    add_action( 'plugins_loaded', 'mycred_init_wpecom_construct_gateway' );

    to

    add_action( 'after_setup_theme', 'mycred_init_wpecom_construct_gateway' );

    http://wordpress.org/plugins/mycred/

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • myCRED
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic