Support » Plugin: Easy HTTPS Redirection (SSL) » Support https terminating load balancers / reverse proxies

  • In the new environment I’m moving a WordPress site using this plugin to, HTTPS is terminated by an internal load balancing proxy instead of terminated by Apache.

    I have WordPress working fine because I have Apache configured with SetEnvIf x-forwarded-proto https HTTPS=on to ensure that PHP/WordPress correctly see $_SERVER['HTTPS'] == 'on' when visiting HTTPS.

    However because the .htaccess code this plugin inserts uses RewriteCond %{SERVER_PORT} !^443$ which means it still gives the infinite loop.

    Could the plugin be updated to have an option to allow RewriteCond %{ENV:HTTPS} !^on$ [NC] to be used instead.

    Or at least, could we have an option to enable the plugin and get the resource url changing behaviour, but disable the .htaccess updating behaviour so we can manually make our own https redirect.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support mbrsolution

    (@mbrsolution)

    Hi, thank you for your question and suggestion. I have submitted a message to the developers to investigate further your request.

    Kind regards

    Plugin Author mra13

    (@mra13)

    Enable the settings in the plugin then let it update the .htaccess file when you save the settings. Then you can manually update the .htacess file yourself and it will use whatever you have in your file. The plugin only updates the file when you save the settings.

    This way, you will get the following behavior

    Could we have an option to enable the plugin and get the resource url changing behaviour

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Support https terminating load balancers / reverse proxies’ is closed to new replies.