Support » Plugin: User Role Editor » support for qTranslate plugin

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Vladimir Garagulia

    (@shinephp)

    I suppose that qTranslate doesn’t translate WP admin back-end or other plugins interface itself. It uses .mo translation files to make that. If you need to see User Role Editor in your language just contribute into its translation. Take .pot file from the lang subdirectory, rename it into .po file according to your language.
    Check this page if needed http://codex.wordpress.org/WordPress_in_Your_Language
    Then translate it using poedit or other tool. If you send translation file to (my first name [at-sign] shinephp.com) URE will support your language.

    Hi Vladimir,

    I have found the problem:

    In file user-role-editor.php on line 57
    load_plugin_textdomain('ure','', $urePluginDirName.'/lang');

    I changed it to

    function init_textdomain() {
    load_plugin_textdomain('ure','', dirname( plugin_basename(__FILE__) ).'/lang');
    }
    add_action('init', 'init_textdomain');

    Now the language switch woks fine with qtranslate! 🙂

    It is possible to change that in the next version?

    Plugin Author Vladimir Garagulia

    (@shinephp)

    Yes I will implement this with next update. You will not lose it. Thanks for the hint :).

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘support for qTranslate plugin’ is closed to new replies.