Support » Plugin: Easy WP SMTP - WordPress Email SMTP Plugin » Support for MFA with MS365

  • Resolved Jay

    (@jaytfl)


    Hello,

    After enabling the MFA for my account which was earlier configured with Easy WP SMTP Plugin, it has stopped working.

    It returns me below error:

    CLIENT -> SERVER: [credentials hidden]CLIENT -> SERVER: [credentials hidden]SMTP ERROR: Password command failed: 535 5.7.139 Authentication unsuccessful, the request did not meet the criteria to be authenticated successfully. Contact your administrator. [PN3PR01CA0176.INDPRD01.PROD.OUTLOOK.COM]
    SMTP Error: Could not authenticate.CLIENT -> SERVER: QUIT
    SMTP Error: Could not authenticate.

    Do let me know if there is anything else to be done to make the account having MFA, to work with this plugin settings.

Viewing 8 replies - 1 through 8 (of 8 total)
  • mbrsolution

    (@mbrsolution)

    Hi,

    Can you check the following troubleshooting steps.

    https://wordpress.org/support/topic/smtp-connect-failed-error-read-before-posting/

    Thank you.

    Thread Starter Jay

    (@jaytfl)

    Hello,

    The username and the password being entered are correct.

    The reason this may have stopped working, as I explained in my earlier message, could be because of enabling MFA because it was working fine all this while.

    Below are the settings from my Outlook:

    Server name: smtp.office365.com
    Port: 587
    Encryption method: STARTTLS

    Which are the exact settings that I’ve applied.

    Let me know how can we get this issue resolved.

    mbrsolution

    (@mbrsolution)

    Hi,

    The reason this may have stopped working, as I explained in my earlier message, could be because of enabling MFA because it was working fine all this while.

    Yes, this could be the issue. However you might like to try the following, see if this works for you.

    Server name: smtp.microsoft.com
    Port: 587
    Encryption method: STARTTLS

    Let me know how you go.

    Kind regards.

    Thread Starter Jay

    (@jaytfl)

    Hello,

    It doesn’t work. It returns

    “SMTP ERROR: Failed to connect to server: Connection timed out (110)SMTP Error: Could not connect to SMTP host.”

    Let me know if the plugin ACTUALLY works with MFA enabled logins or not.

    Thanks!

    Hi,

    Let me know if the plugin ACTUALLY works with MFA enabled logins or not.

    Unfortunately I have never tested this myself. I have submitted a message to the developers to investigate further your issue.

    Kind regards.

    Thread Starter Jay

    (@jaytfl)

    How long should I expect to receive any response from your end?

    Just asking to see if we need to think of an alternate solution or not.

    Thanks!

    Thread Starter Jay

    (@jaytfl)

    Hello?

    Plugin Support Dake

    (@dakeg)

    Hey @jaytfl

    Thanks for reaching out and we apologise for the delay.

    Since you have enabled Multi-Factor Authentication (2 Factor Authentication) on your Office 365 email account, you need to set up an App Password within your Office 365 account settings (see https://a.supportally.com/NVWZpR) and then you can use that App Password

    As long as you’re using an App Password, you should be good. Basically, Microsoft made a change on their end that won’t allow you to connect with your normal password. Instead, you can create an App Password in your Microsoft account and use that.

    In case it helps, this guide on their site will walk you through creating an App Password:

    https://support.microsoft.com/en-us/account-billing/using-app-passwords-with-apps-that-don-t-support-two-step-verification-5896ed9b-4263-e681-128a-a6f2979a7944

    Just use it in place of your regular password and your SMTP connection should be good.

    I hope that helps!

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.