Support » Plugin: Permalink Manager Lite » Support for custom post type and custom taxonomies?

  • Resolved azurblossom

    (@azurblossom)


    I have a problem with setting up the correct permalinks.

    I use the latest version of Rank Math and Permalink Manager Pro to customize my URLs.

    I have a page that uses a custom post type for products where some products are assigned to mutliple product custom taxonomy terms, i.e. category_1 and category_2

    In Rank Math I use “Make Term Primary” to set the category I’d like to have in my permalink (and Breadcrumb) to get the following permalink structure:

    domain.com/primary-term-set-in-rank-math/product-title/

    Unfortunately the permalink is always constructed in such a way that the first alphabetical product category is taken:

    domain.com/first-avaiblable-alphabetical-category/product-title/

    If I understand it correctly, Permalink Manager supports this since version 2.2.7.4, but can’t get it to work correctly.

    I don’t know what I’m doing wrong and hope anyone can help me with this.

    Any ideas?

    Thank you very much for your support.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Maciej Bis

    (@mbis)

    Hi @azurblossom,

    Please accept my apology for the inconvenience!

    The primary term were supported initially for regular categories. Could you replace the contents of permalink-manager-pro/includes/core/permalink-manager-helper-functions.php with the below code?
    https://pastebin.com/n0ybxNux

    This should make my plugin support primary terms set for other taxonomies added to the custom permalinks. This code adjustment will be also present in the new plugin versions.

    If you need any further assistance please contact me via email: contact /at/ maciejbis.net.

    Best regards,
    Maciej

    Hi @mbis,

    Thank you very much for your reply.

    I replaced the code in permalink-manager-helper-functions.php and the adjustments solved it.

    Keep up your great work.

    Best regards,
    Azur

    Hi @mbis,

    I have a follow-up question.

    I have noticed that the URL is not updated when I use the Regenerate tool, but only when I edit the post individually.

    When I run the regenerate tool again, all slugs will be put back into the alphabetical order.

    Any idea?

    Plugin Author Maciej Bis

    (@mbis)

    Hi @azurblossom,

    Could you send me a few sample screenshot with URI editor opened:

    • before the URLs are regenerated
    • after the URLs are regenerated

    Plugin Author Maciej Bis

    (@mbis)

    I think that this might be also helpful.

    Please note that all manual changes to the custom permalink will be overwritten when “Regenerate/reset” tool is used. As the name suggest, after the process the custom permalink will be reverted to “Default URI“.

    To prevent this from happening, you can select “No (ignore this URI in bulk tools)” option in “Auto-update the URI” dropdown.

    Hi @mbis,

    I’ve changed the URIs now by using your Find/Replace tool. I prepare some chronological screenshots tomorrow and send you the link.

    Thanks for your help,
    Azur

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.