Support » Plugin: Avatar Privacy » Support for ClassicPress in the future?

  • Resolved seanking2919

    (@seanking2919)


    Hi,

    I saw in the changelog for the latest update that 2.2.x will be the last version branch to support WordPress < 5.2. Does this mean all support for ClassicPress will be gone as well?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author pepe

    (@pputzer)

    The next version will drop PHP 5.2 boostrap compatibility and require WordPress 5.2 in the readme.txt. At the moment there are no concrete plans for using 5.2 APIs, but the may arise in the future. Does ClassicPress follow WordPress development in any way (API and version-wise)? Does it have any special readme.txt tags to determine plugin compatibility?

    Plugin Author pepe

    (@pputzer)

    Apropos, @seanking2919, what version of Avatar Privacy did you use before I released 2.2.2? If it was 2.2.1, raising the required WordPress version doesn’t have any ill effect on ClassicPress (it was at 5.1 already, now dropped back to 4.9 for 2.2.2).

    Plugin Author pepe

    (@pputzer)

    @seanking2919 Can you tell me which version of Avatar Privacy you had installed before 2.2.2?

    Yeah, I used 2.2.1 before 2.2.2

    Plugin Author pepe

    (@pputzer)

    Then I think you’ll be good on ClassicPress with 2.3.x as well.

    Plugin Author pepe

    (@pputzer)

    FYI, I’ve ultimately decided to keep the WordPress version requirement at 4.9 in Avatar Privacy 2.3.0 – WordPress 5.2 is just not widespread enough yet do completely ditch PHP 5.2 boostrapping. The required WordPress version will be increased with Avatar Privacy 3.0, though.

    Curious… Why can’t you just ditch PHP 5.2 support without requiring WordPress 5.2? I didn’t even think anything ran on PHP 5.2 anymore…

    Plugin Author pepe

    (@pputzer)

    Technically, before 5.2 nothing prevents the plugin from being activated even if the declared PHP version requirement is not met. So to prevent whitescreeing for older WordPress installations, I have to have PHP-5.2-compatible “boot loader” that checks for PHP 5.6+ before really instantiating the plugin.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.