Support » Plugin: Cielo WooCommerce - Solução Webservice » Suporte para o Webservice 3.0

  • Plugin Author Claudio Sanches

    (@claudiosanches)


    Estou trabalhando para adicionar suporte ao Webservice 3.0, mas como vocês sabem, eu mantenho os outros plugins e todos agora precisam de atualização para a nova versão do WooCommerce, então vai levar algum tempo para ficar pronto.

    É possível me ajudar a desenvolver essa nova versão no GitHub: https://github.com/greguly/cielo-woocommerce

Viewing 15 replies - 16 through 30 (of 46 total)
  • Pessoal, e Claudio, vou responder em seu nome aqui pois já sei de algumas respostas que você provavelmente não tem tempo de vir aqui deixar.

    Esse plugin aqui tem suporte APENAS para o 1.5 e a atualização para o 3.0 talvez se torne um plugin diferente, pois a nova API mudou bastante e se atualizar esse daqui pode fazer com que o serviço deixe de funcionar para todos que usam o 1.5.

    Ele já recebeu essa informação, já houve PR no Github com atualização e essa foi a resposta dele:
    let me check it first, because maybe if the amount of changes required, maybe it’s more easy start a new plugin for it, since it’s confuse enough for the users today.

    WordPress é uma comunidade, não um exército de um homem só pessoal.
    Desenvolvedores disponíveis e amantes da plataforma, ajudem quando possível.

    O Claudio já tem uns 60 plugins aí na comunidade pra manter gratuitamente além do trabalho dele na Automattic/WooCommerce.

    Não esqueçam pessoal, o Claudio não recebe nada pra fazer o que faz, não tem obrigação de manter, muito menos de dar suporte. Ele fez a versão 1.5 e, por um grande desvio a Cielo lançou a 3.0 e desativou a 1.5.

    Vamos tentar ajudar mais, trazer mais desenvolvedores, tirar um pouco da sobrecarga dos poucos desenvolvedores BR’s.

    Abraços a todos.

    @designroom Boa tarde , Na verdade nem dei ainda um fork , fiquei de reinstalar meu linux hoje e acabou de chegar o livro do WordPress pra eu da uma estudada, nunca programei via wp , como é php acredito que meu desenvolvimento será mais rápido , e aparentemente pelo que li são classes e mais classes mas a falta de experiência em wp e wc posso demorar ;
    Eu terminei de estudar o manual de programação da cielo e meus teste via Angular Js todos passaram.

    Previsto pra segunda-feira que vem da inicio ao plugin.

    • This reply was modified 2 years, 1 month ago by adnilton.
    habilce

    (@habilce)

    @adnilton Bom dia. Como vai os trabalhos para o desenvolvimento do plugin? Você tem alguma previsão de lançamento? Obrigado.

    Seria possível algum feedback sobre a atualização API 3.0?

    Desde já agradeço muito,

    Olá, tudo bom?
    Poderiam me informar quais as versões de wp e wc compatíveis com o plugin atual?
    Consegui a liberação para utilizar a API 1.5 da Cielo, mas ao realizar os testes para homologação recebo o erro: “Cartão de crédito: Um erro aconteceu ao processar o seu pagamento, por favor, tente novamente ou entre em contato para conseguir assistência.”

    Estou utilizando as versões:
    Woocommerce – Versão 3.2.6
    Wordpress – Versão 4.9.1

    Desde já, agradeço pela atenção!

    Pessoal há alguma previsão para o lançamento da versão compativel com a API 3.0 da CIELO? Penso que poderia ser uma boa ideia a comunidade aqui do WordPress que usa o plugin participar de uma vaquinha para o time do Claudio dar um gaz no plugin, o que pensam a respeito? Entre pagar pelo plugin que estão vendendo ai e participar da Vaquinha, sem duvida optaria pela Vaquinha. Visto que os DEVs da equipe são ótimos.

    Alguém sabe dizer se estão trabalhando na atualização do plugin ainda?

    Concordo @mariocsoliveira

    E consegui colocar pra funcionar a versão 1.5 da API, é compatível com as versões mais novas do WP e WC. Havia perguntado, mas não obtive resposta.
    Abraço!

    Pois é @robsonsza

    Comigo não deu certo, estão regulando a liberação e o atraso já é indicio de problema a vista, vou me organizar para usar outro fornecedor, um que vi foi o abaixo, voce conhece? É bom?

    http://www.jrossetto.com.br/minha-loja/wordpress/cielo-api-3-0-woocommerce-credito-debito-boleto-nova-opcao-disponivel/

    @mariocsoliveira
    Meu brother, me chama no whatsapp: (31)994617215
    Vou te passar como fiz pra conseguir a liberação pra integração na 1.5.
    Abraço!

    Galera, navegando pelo Github, encontrei um SDK em PHP da API 3.0 da Cielo com muitos métodos prontos para transações crédito/débito e pagamentos recorrentes, incluindo boleto: https://github.com/izapbrasil/cielo-api-3.0-php

    O SDK já trata os dados no formato JSON exigido pela nova API. “Não há limitações para transações feitas no ambiente da loja com o SDK, mas o desenvolvedor tem que tratar os dados quando se faz necessário qualquer tipo de autenticação e redirecionamentos fora do ambiente da loja”.

    A API 3.0 da Cielo já entrou em vigor há um tempão… Cadê a galera expert em desenvolvimento?! Bora contribuir gente! Zueira 🙂 sem pressão… Mas testei o SDK no modo sandbox e deu tudo certo. Pena que minhas habilidades de “implementação” estão longe de serem habilidades de desenvolvimento, do contrário, já estaria contibuindo no Github com pull requests!

    Espero que o pessoal da comunidade WP/Woocommerce chegue junto e contribua com a continuação do plugin!

    A situação é grave mesmo. O webservices 1.5 da Cielo será desligado em maio de 2018.
    Vou ver como posso contribuir neste fim de semana, mas faz um tempo que não desenvolvo pra WordPress e qq ajuda seria ótimo.
    @designroom vou ver a sdk que citou.

    Galera, não tenho conhecimentos em programação e desenvolvimento para colaborar. Apoio a “vaquinha” como foi sugerido anteriormente, poderíamos organizar isso pra dar uma força pra quem se dispuser a ajudar. Outra possibilidade é organizar um abaixo-assinado, criar uma página ou grupo em alguma rede social, para juntar os utilizadores da plataforma e solicitar à Cielo que prorrogue o prazo de desligamento da API 1.5 até que consigam liberar a 3.0.
    O que acham?

    Pessoal.. baixei a ultima pull request deste plugin em https://github.com/greguly/cielo-woocommerce e em ambiente de testes da Cielo funcionou corretamente na aprovação dos pedidos, entretanto não consegui reproduzir os comportamentos esperados pelos finais dos cartões de testes especificados no manual de testes.

    Esta é a página com a lista de cartões e o comportamento esperado:
    https://developercielo.github.io/manual/cielo-ecommerce#cart%C3%A3o-de-cr%C3%A9dito-sandbox

    @ttiagorrodrigues e @claudiosanches, sabem me dizer o que falta ser feito neste plugin?
    Assim poderei ajudar.

    @claudiosanches Como vai? Espero que bem. Pode nos dar um norte sobre este plugin. Será mantido? Está em andamento? Creio que os interessados não conseguem ajudar muito com programação, mas com testes e financeiramente creio que sim. Obrigado.

Viewing 15 replies - 16 through 30 (of 46 total)
  • You must be logged in to reply to this topic.