Support » Plugin: Super Progressive Web Apps » superpwa-sw.js

  • Hi,

    There is a mistake in the “superpwa-sw.js” file (a “/” is missing). I have to change it from const neverCacheUrls = [/\/wp-admin/,/\/wp-login/,/preview=true/,/\/realmedialibrary\/v1]; to const neverCacheUrls = [/\/wp-admin/,/\/wp-login/,/preview=true/,/\/realmedialibrary\/v1/];.

    Unfortunately, the file “superpwa-sw.js” does not exist in my WordPress directory (but it’s accessible via browser). I can create this file, change the line and then it works. But if I make changes to the settings of SuperPWA (https://domain.com/wp-admin/admin.php?page=superpwa) the file is removed.

    How to fix this?

    Thanks,
    Mark

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author SuperPWA

    (@superpwa)

    Can you please send us the URL of your website? And also can you please let us know where you are placing that realmedialibrary link? is it from exclude from cache option or by hardcoded?

    Thread Starter mschmale

    (@mschmale)

    @superpwa

    Thanks for your quick reply.

    I did not place the realmedialibrary link there. Could you please check if this comes from your plugin? If this is not from your plugin, I have to contact the developer of Real Media Library.

    Plugin Author SuperPWA

    (@superpwa)

    Our plugin won’t place that realmedialibrary link but we provide a filter using that. Other developers or plugins can add other links for no-cache.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.