Support » Plugin: Super Progressive Web Apps » SuperPWA 2.0 : Service worker not really generated

  • Resolved ariestwn

    (@ariestwn)


    Hello,

    i’ve updated the plugin from 1.9 to 2.0, on the page superpwa -> settings. it show “Service worker generated successfully”, but when i click the url, the file got 404 not found.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 27 total)
  • Plugin Author Arun Basil Lal

    (@arunbasillal)

    Hello @ariestwn,

    Thanks for upgrading, however that unfortunate. The core reason is that WordPress isn’t loaded when the service worker is requested because of the server config.

    – I noticed you were on NGINX, is it NGINX on Apache?
    – Does it happen only for the service worker or is it the same for both service worker and manifest?

    Looking forward to your feedback.

    Plugin Author Jose Varghese

    (@josevarghese)

    Hi @ariestwn,

    Adding a bit more to Arun’s reply.

    Can you please deactivate the OneSignal plugin and try the same.

    IE; As first deactivate the OneSignal plugin, After deactivation check whether the service worker link within our plugins Status section, can it be seen now without any 404 error? If you can see the service worker file, it will be mostly because of any security plugins blocking the .php file extensions for the earlier SW file.

    Looking forward to hearing your thoughts.

    same issue here
    service worker and manifest file

    yep I’m seeing this also, both service worker and manifest file not generated. Not using OneSignal plugin, and am on shared hosting LAMP.

    yup same here not using OneSignal

    I rollback to 1.9 working fine
    2.0 causes the issue.

    Plugin Author Jose Varghese

    (@josevarghese)

    @worldfacts @androweb Please do open a new thread with your respective website URL, so that we can look more specifically over it.

    Hi @arunbasillal
    thanks for replying. i think the problem is not caused by web server. yes i’m running my website on nginx.

    @josevarghese
    Thankyou for replying, before the problem solved. i installed older version of the plugin 1.9. and i deactivate the latest version of the plugin 2.0 until my ticket got replied you guys.

    after reading your reply, i deactivate the onesignal plugin and older version of superpwa. and then activate latest version of the plugin. On this case, service worker is run perfectly. after that i activate the onesignal plugin, set the superpwa manifest. and the problem was solved completely.

    but, why the file OneSignalSDKWorker.js.php show cacheName as superpwa-1.9 ?

    Plugin Author Jose Varghese

    (@josevarghese)

    but, why the file OneSignalSDKWorker.js.php show cacheName as superpwa-1.9 ?

    I think a cached OneSignalSDKUpdater.js.php file is serving from your server. Can you please flush the cache upon the server? (If you are using Cloudflare, don’t forget to clear the cache from it too)

    Looking forward.

    and yup, after deleting the cache from server. the service worker return 404 again. note: i only run the plugin superpwa. the plugin from onesignal is deactivate.

    Plugin Author Jose Varghese

    (@josevarghese)

    Can you please let me know whether you are using any security plugins over the website?

    no, i’m not using any security plugins.

    Plugin Author Arun Basil Lal

    (@arunbasillal)

    Hello @ariestwn

    I just checked your website, I suppose SuperPWA is deactivated for now?

    I couldn’t tell if it was the same issue. Can you try this solution and see if it works for you as well? – https://wordpress.org/support/topic/2-0-service-worker-and-manifest-file-not-generated/#post-11034018

    Looking forward to your feedback.

    I have tried it a few hours ago. and not change anything. if it was the problem from our server. then why the older version of the pluggin work perfectly ?

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘SuperPWA 2.0 : Service worker not really generated’ is closed to new replies.