WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Supernova - Name, email, site, hidden for Comments, Please Help! (5 posts)

  1. HowieJ80
    Member
    Posted 6 months ago #

    I am using the Supernova theme and it was just brought to my attention that when visitors are trying to leave comments, they are not seeing the fields to fill ou their name, email, website, etc. The only way for the fields to appear seems to be when you click within the comment box. However, I want these fields to be visible. If someone is leaving a comment and leaves this blank, it is not only giving them an error message, but also deleting the entire comment. It is causing my visitors to leave without leaving a comment. How can I set up these fields so that they are embedded into the posts and pages, instead of hidden and only popping up when you click in a certain field? I truly appreciate any assistance with this issue ASAP. Thank you in advance!

  2. CrouchingBruin
    Member
    Posted 6 months ago #

    You should always post a link to your site so we can examine it directly and see what the problem might be.

  3. CrouchingBruin
    Member
    Posted 6 months ago #

    Yes, that's very weird how the theme author did that.

    From the admin dashboard, go to Appearance > Supernova Options and click on the Styling tab. Scroll down until you see the big black field that's labeled Write Custom CSS, and copy & paste this into it:

    #commentform #author,
    #commentform #email,
    #commentform #url {
       display: inline-block !important;
    }

    Then click the Save Settings button. Those fields should now display all the time.

    If you have other questions related to the Supernova theme, you should post them in their support forum; you're more likely to get an answer from someone (like the theme developer) who is familiar with the theme over there.

  4. HowieJ80
    Member
    Posted 6 months ago #

    CourchingBruin,

    I can't thank you enough! That is MUCH better and in my opinion, more clear for my visitors to see when filling out a comment. I sincerely appreciate your assistance. Also, the site is http://focushereandnow.com if you want to take a look and see what I meant. It is not displayed after adding the CSS code that you provided above. Again, thank you very much for your help!

    Howie

  5. Sayed Taqui
    Member
    Posted 6 months ago #

    when visitors are trying to leave comments, they are not seeing the fields to fill ou their name, email, website, etc. The only way for the fields to appear seems to be when you click within the comment box.

    I did that purposely because it looks more clean. However if you dont want it, the above css should work as I can see.

    If someone is leaving a comment and leaves this blank, it is not only giving them an error message, but also deleting the entire comment. It is causing my visitors to leave without leaving a comment.

    I agree with you here, wordpress does it by default unless we use some javascript to prevent this. I'll fix it in the next version which is coming very soon. Meanwhile use this script.

    (function($){
      $(document).ready(function() {
          $('#commentform').find('#submit').on('click', function(e){
              if( $('input#author').val() === '' ||  $('input#email').val() === '' ){
                  $('input#author, input#email').css('border', '1px solid red');
                  alert('Please Enter Your Name and Your Email.');
                  e.preventDefault(); return;
              }
          });
      });
    })(jQuery);

    Paste this under Supernova Options > Advanced > Header Script

Reply

You must log in to post.

About this Topic