Support » Plugin: WordPress SuperSonic with CloudFlare » Superfluous parameters on some pages

  • 1. When editing a post the plugin adds ?supersonic=wp-admin/ to the permalink preview.
    2. When using Publicize (from Jetpack) to post on Facebook, the address on the post shouldn’t include the supersonic parameter.

Viewing 10 replies - 1 through 10 (of 10 total)
  • ad 2. Links on the Facebook look like this:
    https://sp13bielsko.pl/wp/?p=1850&supersonic=wp-admin
    Without SuperSonic Publicize posts the correct link:
    https://sp13bielsko.pl/wp/2016/09/informacje/wycieczka-do-chlebowej-chaty-klas-iiie-i-iiid/

    Plugin Author kursorA

    (@kursora)

    This additional parameters are generated when “Do not logout user roles” is enabled.
    There is no other method to realize this functionality.

    Sure, but I don’t want to have them on the Facebook posts. Users from Facebook will see it anonymously.

    Plugin Author kursorA

    (@kursora)

    Then you must disable this option.

    Chyba się nie rozumiemy. Podczas używania WordPressa jak najbardziej potrzebuję tej opcji, ale link wysyłany na Facebooka nie powinien zawierać tych parametrów, bo i po co. Ale najgorsze w tym wszystkim jest to, że adres publikuje się w postaci skróconej (?p=1850), a nie jako przyjazny link.

    Plugin Author kursorA

    (@kursora)

    Rozumiemy się.
    Po prostu nie ma możliwości stwierdzenia kiedy ma być dodany ten parametr, a kiedy nie.

    Jeżeli jest włączona opcja niewylogowywania to ten parametr dodawany jest zawsze do każdego linku generowanego przez wordpressa w czasie gdy użytkownik jest zalogowany.

    Nie da się wykryć, że to jest link pobierany przez Publicize? I dlaczego po włączeniu SuperSonica nie są na Facebooka wysyłane przyjazne linki, tylko skrócone?

    Come on guys, can you speak in english so everybody can realize what are you talking about? From what I can translate using Google, the main conclusion is: there is no other workaround than just deactivate the “Do not logout user roles” option.

    It’s not a marvelous workaround but did the trick in some scenarios.

    Plugin Author kursorA

    (@kursora)

    Please check version 1.8.1 – this problem should be fixed.

    Great! v1.8.1 fixed the post link in the editor. Checked.
    I don’t use Publicize so I hope it work for @cezariuszmarek

    I do use Shareaholic and I will ask them to check whether Supersonic is installed and active in order to strip the “?supersonic=wp-admin” parameter.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Superfluous parameters on some pages’ is closed to new replies.