Support » Fixing WordPress » Super weird bug: Site redirecting to specific single post

  • This is weird and I can’t find a solution so far:

    Somehow my wordpress site’s root url is now redirecting to a specific blog post (incidentally one that I just created an hour ago), instead of the Main Index Page. No matter what I do, click on the header/home page link, type the url into the address bar myself, redirects to . No other pages like category pages and singe pages redirect.

    Worse, I went and deleted the offending blog post and now the home page shows a 404 error!

    Anyone know if this is a wordpress 3.0 beta problem? It was installed automatically by cpanel and I wouldn’t even know how to downgrade if that’s the problem.

Viewing 9 replies - 1 through 9 (of 9 total)
  • And now I fiddled around with it and instead of going to that blog post, going to the root url now shows the “redirecting in a way that will never be resolved” error.

    What is going on here!?

    Well, great. I deactivated/reactivated some plugins/widgets, and now the site functions again. Sadly I have no advice for others other than doing the same. If someone ever figures out exactly what the issue is it owuld be helpful to others.

    wow! same here I’m encountering this weird wordpress bug as well.. geeeeeeez.. it’s annoying. O_O

    I also discovered this problem after upgrading to WordPress 3.0. I deactivated plug-ins and it made no difference. But then I tried a second time just deactivating the Redirection plug-in, which corrected one of the pages that was redirecting, but not the other. I was able to get the other to work by deleting it and recreating it…although that had NOT worked when the Redirection plugin was still activated.

    Found a number of similar posts around the forums about redirection problems…I’m guessing it may be tied in to the new menu feature? Just a guess. I was playing around with that, then went back to how I had it prior to the 3.0 upgrade (main menu done in Thesis, secondary menus done in WP Menu Manager). It was after a lot of building and deleting menus and moving menu items around that the problem appeared.

    Weird thing is that I had not put in any redirects using the Redirection plug-in…it’s just something I have loaded up for when I get ready to take the site live.

    I reactivated the Redirection plug-in and the problem reoccurred. So I’ve found the culprit for my own issue, at least.

    I’ve had exactly the same issue and found the cause to be the Redirection plugin. Hopefully the creator of this plugin will fix this issue in the next update.

    yep … me too – I was having the same problems … took forever to nail it (just need to know what search terms to put into support search!).

    I’ve been using redirect plugin for about 12 months without problems, I guess I must’ve upgraded (to v 2.2) without thinking about it.

    I was using redirect with wp.3.0.3.

    Disabled redirect and now things are cool.

    However, I now don’t have the redirects, and this plugin used to work great 🙁

    On another thread somewhere in the universe the same thing was reported when WP went from the 2’s up to 3.0.

    Yes. The culprit was and probably is again Redirection.

    The solution was/is to go into the redirection options and switch off URL monitoring.

    Then, when you post, save as a draft first then post and all should be ok until the developer updats the plugin with a fix.

    Just confirming that yes!

    The homepage redirecting to a blog post BUG…
    is a Redirect Plugin problem
    (seems to occur after lulling you into a false sense of security)

    BUT! it can be fixed in the REDIRECT settings.

    FIRST – fix the first problem
    —— Go to you hosting cpanel
    —— Go to MyPHPadmin
    —— Click on your wp-blogs database
    —— In left column click on wp_redirection_items
    – You will see one or two entries that are redirect home page which appears as ‘/’ to the culprit blog post url
    —— Delete those entries (‘/’ is your home page)

    NOW – Stop it from happening again!!!
    —- Go to your wordpress wp-admin login
    —- Click on the redirection settings (left column under Tools)
    —- Choose OPTIONS from Redirects | Groups | Modules | Log | OPTIONS | Support
    —- Select “Don’t monitor” from the drop down and update

    This is the Redirect feature that is creating a bug, usually when you change the URL permalink of a blog post.

    Hope That Helps!!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Super weird bug: Site redirecting to specific single post’ is closed to new replies.