Support » Plugin: WP Super Cache » Super cache stopped working after upgrade to 4.9

  • After upgrading to 4.9, I browsed through the admin and saw this on what should have been the wp super cache admin page

    “Warning! Could not update /home/SITENAMEl/wp-config.php! WPCACHEHOME must be set in config file.
    Warning! /home/SITENAME/wp-content/advanced-cache.php does not exist or cannot be updated.

    If it already exists, please delete the file first.
    Make /home/SIENAME/wp-content writable using the chmod command through your ftp or server software. (chmod 777 /home/SITENAME/wp-content) and refresh this page. This is only a temporary measure and you’ll have to make it read only afterwards again. (Change 777 to 755 in the previous command)
    Refresh this page to update /home/SITENAME/wp-content/advanced-cache.php

    If that doesn’t work, make sure the file /home/SITENAME/wp-content/advanced-cache.php doesn’t exist:

    Open /home/SITENAME/wp-content/plugins/wp-super-cache/advanced-cache.php in a text editor.
    Change the text CACHEHOME to /home/SITENAME/wp-content/plugins/wp-super-cache/
    Save the file and copy it to /home/SITENAME/wp-content/advanced-cache.php and refresh this page.

    I have been using wp super cache for many years with no issues

    I checked wp-config filke and could see 2 lines that were super cache related

    define( ‘WPCACHEHOME’, ‘/home/SITENAME/wp-content/plugins/wp-super-cache/’ ); //Added by WP-Cache Manager

    and further down
    define(‘WP_CACHE’, true); //Added by WP-Cache Manager

    I deleted caches, removed the advanced cache.php file, removed the lines from wp-config, removed the htaccess lines and deleted the plugin

    I installed a new copy set the wp-content and wp-config to 777

    The same error messages appeared

    I added the lines back to wp-config with no joy

    I do not understand the instructions re advanced-cache’php as it say to replace the text CACHEHOME whereas there is no CACHEHOME only 2 mentions of WPCACHEHOME

    Nt sure if this is down to the 4.9 upgrade happening today or if this occuured previously

    • This topic was modified 1 year, 3 months ago by  .
Viewing 9 replies - 1 through 9 (of 9 total)
  • “Progress” of a sort

    I now get
    Warning! WP Super Cache caching was broken but has been fixed! The script advanced-cache.php could not load wp-cache-phase1.php.

    The file /home/SITE/wp-content/advanced-cache.php has been recreated and WPCACHEHOME fixed in your wp-config.php. Reload to hide this message.
    Warning! Could not update /home/SITE/wp-config.php! WPCACHEHOME must be set in config file.

    When I click on a button on the plugin admin, I get

    Warning! You must set WP_CACHE and WPCACHEHOME in your wp-config.php for this plugin to work correctly:
    define( ‘WP_CACHE’, true );
    define( ‘WPCACHEHOME’, ‘/home/SITE/wp-content/plugins/wp-super-cache’ );

    Both lines are in the wp-config file

    Same here. Lines are first in wp-config.php, yet the warning persists and super cache remains disabled.

    jonathanmoorebcsorg

    (@jonathanmoorebcsorg)

    similar here, after wordpress 4.9 update, stuck on:

    Rewrite rules must be updated

    The rewrite rules required by this plugin have changed or are missing. Scroll down the Advanced Settings page and click the Update Mod_Rewrite Rules button.

    this applies to multiple sites, simple and complex

    THe htaccess rewrite issue is a known bug with WP and will be fixed in 4.9.1

    jonathanmoorebcsorg

    (@jonathanmoorebcsorg)

    thanks, is commented on:
    https://core.trac.wordpress.org/ticket/42579

    it looks like a coding standards review changed the logic, adding a brace to the the one line if statement changed it to multiline statement which meant the next line could never be true.

    if ( false !== strpos( $markerline, '# END ' . $marker ) )
       $state = false;  
       if ( $state ) {

    I hope there’s no more of those hidden in 4.9…

    Saša

    (@stodorovic)

    Hi @steveb123,

    I think that I see source of issue related to WPCACHEHOME. I tried to create this PR which should fix it. Also, it could be problem with opcache which should fix this PR.

    I open to help you if you want to test these changes.

    Regards,
    Sasa

    Thanks for getting back to me, I will see if I can find some time tomorrow to test.

    Any idea as to when this might be released as an update?

    Saša

    (@stodorovic)

    There are new PR – https://github.com/Automattic/wp-super-cache/pull/465 and it’s merged into master. So, you can try to download master from github. It’s possible that master from github has some issues related to translations (it affects only admin dashboard).

    You could wait updated development version. Anyway, I’ll try to update this topic when I know more details.

    Hi Sasa,

    Downloaded, unzipped and uploaded Master from GitHub

    On activation and going to wp-supercache Admin page, I get a blank page

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Super cache stopped working after upgrade to 4.9’ is closed to new replies.