WordPress.org

Support

Support » How-To and Troubleshooting » Super-Cache Installs Activates, creates files, but no caching done.

Super-Cache Installs Activates, creates files, but no caching done.

  • Hey eveyrone, im so sory to have to start up another thread reguarding supercache.

    Ive heard such great things and my hosting loves it, so i paid someone to go and install super-cache on all my blogs.

    Hoping it was going to be simple, upload, install, activate, etc.

    Super-Cache installs, activates, adds mod-rewrites, etc.

    BUT all my pages still say 0 cached pages.

    Here is my site:

    http://ibeatweightloss.com

    I just don’t know where to begin to troubleshoot this.

    Im not even trying to used the gzip compression, just simple super-cache.

    P.S. For some reason i had to create the ‘supercache’ folder inside the cache folder, but it still is not caching any files.

    .htaccess code in the root of the site

    # BEGIN WPSuperCache
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    AddDefaultCharset UTF-8
    RewriteCond %{QUERY_STRING} !.*s=.*
    RewriteCond %{QUERY_STRING} !.*attachment_id=.*
    RewriteCond %{HTTP_COOKIE} !^.*(comment_author_|wordpress|wp-postpass_).*$
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz -f
    RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz [L]
    
    RewriteCond %{QUERY_STRING} !.*s=.*
    RewriteCond %{QUERY_STRING} !.*attachment_id=.*
    RewriteCond %{HTTP_COOKIE} !^.*(comment_author_|wordpress|wp-postpass_).*$
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html -f
    RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html [L]
    </IfModule>
    
    # END WPSuperCache
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    .htaccess code in the root of cache

    # BEGIN supercache
    AddEncoding x-gzip .gz
    AddType text/html .gz
    # END supercache

    just looking what the next step is to check.

    Thanks!

Viewing 1 replies (of 1 total)
  • P.S.

    I also have the option “show supercache in the footer” or whatever it is, selected, but no luck caching still.

Viewing 1 replies (of 1 total)
  • The topic ‘Super-Cache Installs Activates, creates files, but no caching done.’ is closed to new replies.