Support » Alpha/Beta/RC » Super Admin not shown

  • I managed to activate multisite and to append my htaccess file, but still, in the back-end the Super-Admin menu item is not shown.

    php_value memory_limit 256M
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    </IfModule>
    
    # END WordPress

    Any help appreciated, Thomas

Viewing 15 replies - 1 through 15 (of 15 total)
  • Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    πŸ³οΈβ€πŸŒˆ Halfelf Rogue & Plugin Review Team Rep

    Are you logged in with the admin account? That is, the account that was the FIRST admin account made on WP?

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Also, log out & log back in again. When activating the network, the instructions on the screen tell you to do this & provide a link.

    @ipstenu: yes, the orignal admin account the only one on the site so far.
    @andrea_r: I followed the instructions to the letter, including your suggestion, emptied any cache I could think of, checked and re-checked my changes to my files, reverted to the default theme and there are no plugins, as this is a new site.

    Maybe I should mention, as well: I have – during the setup procedures – named the system admin not “admin” but a fantasy name. Could this have an impact?

    Regards, Thomas

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    It shouldn’t matter if you’re named “admin” or not anymore.

    Are you on a host where any htaccess or file changes take a while to show up?

    Thanks for taking up this matter again – and the answer is no, besides I made these changes two days ago. As far as settings go, safe-mode is on and register globals is off – are there any others that I should have a look at?

    I should also mention, that in the meantime I have set WP_DDEBUG to true, but that did not throw up any errors either, so I set it to false again.

    Thomas

    OK, so do not ask how I did it (actually, I am going to tell) – but now it works.

    First, as this was a brand new install anyway, I deleted everything and started from scratch, paying particular attention, to what did not sound familiar.

    Now, I could not swear to it, but most likely, in the second set of instructions, where it says “append your wp-config.php (or something to that effect), I mistook the line
    [code]define( ‘MULTISITE’, true );[/code] for the line [code]define(‘WP_ALLOW_MULTISITE’, true);[/code]
    and did not copy that in.

    That is the only line that did not ring a bell the second time round.

    Maybe this is helpful for somebody else one day.

    Regards, Thomas

    I am facing the same problem, but I am 100% certain that the lines are correctly put, with nothing missing (I have just made sure they are).
    I see no super admin menus at all, although the my account is an admin account, and it is the first account through which I made the installation (I upgraded a current WP not installed a fresh one).

    What is it ???

    Richard Archambault

    (@richardmtl)

    Happiness Engineer

    Duh, same here, I idnd’t copy the [code]define( ‘MULTISITE’, true );[/code] line, they look so similar!

    Thanks for the help! πŸ™‚

    Ah ha! Same problem here. Added back [code]define( ‘MULTISITE’, true );[/code] and super admin appeared. Thanks for letting us know.

    I am seeing the same issue. However, I get a Network Admin link at the top right of the page. Is this a change to the UI? Would be nice to update the codex to include this change if that is the case…

    Figured out what happened here – there does appear to be an update to the UI for version 3.1 Alpha, and because I was using the SVN repo for trunk, that it what I was getting. Note to self – don’t use Trunk unless you want to get undocumented features!

    It turns out there is _another_ way to create the same problem. I discovered this the hard way.

    The directions are clear: “Add the following to your wp-config.php file in /Applications/XAMPP/xamppfiles/htdocs/wordpress/ above the line reading /* That’s all, stop editing! Happy blogging. */:”

    I failed to note the bolded above, and put the lines below it. After futzing about for a bit, I re-read the instructions very carefully, discovered my error, took off my shoe, and kicked myself in the head (didn’t want to damage the shoe). I was in a bit of a hurry, and my haste made waste.

    I am having the same problem. However I do have both lines of code in my config file:

    define('WP_ALLOW_MULTISITE', true);
    
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', false );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'flicka3.dk' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );
    
    /* That's all, stop editing! Happy blogging. */

    And my super admin menu is still not showing up. Any idea what might be wrong?

    Is WordPress 3.1.2 not bundled with Super Admin Panel?

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    πŸ³οΈβ€πŸŒˆ Halfelf Rogue & Plugin Review Team Rep

    anuradhaedirisuriya it is, but if you’re having specific problems, please post a NEW topic about it in the MultiSIte section. 3.1.2 isn’t alpha.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Super Admin not shown’ is closed to new replies.