WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Super Admin can’t create Sites (might be related to .htaccess)

[Resolved] Super Admin can’t create Sites (might be related to .htaccess)

  • I have installed WP 3.0 on my school’s server, in a directory allocated to me. I have full FTP privileges to this directory, including file permissions. Everything seems to work fine, except that when I made a change to the permalinks setting and a .htaccess file was created I started to get 500 errors. I had to rename the file to disable it and then everything works fine.

    I switched on multi-site, got the Network option, and completed the multi-site installation without a problem. But, when I try to create a new site from the Super Admin panel, the directory is not created and no WP files are placed there. Super Admin thinks that a site is created (and the appropriate database tables are created), but going to the site (or backend) yields a 404 error.

    I tried to made the changes to my .htaccess that are listed when installing Network mode, but as soon as the file is created it blocks access to the site and the Dashboard (500 error).

    I think that the entire issue is related to the .htaccess file, but I can’t figure out why. Here is the content of the .htaccess file:

    # BEGIN WordPress
    # <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /web/
    RewriteRule ^index\.php$ – [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    </IfModule>

    # END WordPress

Viewing 5 replies - 1 through 5 (of 5 total)
  • Andrea Rennick

    @andrea_r

    Customer Care at Copyblogger Media and Studiopress

    Everything seems to work fine, except that when I made a change to the permalinks setting and a .htaccess file was created I started to get 500 errors. I had to rename the file to disable it and then everything works fine.

    This is going to be an issue and it relates to your problem. 🙂

    But, when I try to create a new site from the Super Admin panel, the directory is not created and no WP files are placed there

    And there won’t be. The site are virtual, they live in the database only. the htaccess file is used to serve up the sites.

    But, as mentioned above, we need it.

    I tried to made the changes to my .htaccess that are listed when installing Network mode, but as soon as the file is created it blocks access to the site and the Dashboard (500 error).

    the 500 error is server based. Have you asked your tech team? What kind of server do you have?
    (crossing my fingers it’s apache…)

    Andrea,

    Thanks for the help. It’s starting to make more sense now. I am waiting on a response to my query about whether we run Apache as the webserver, and what might be causing the .htaccess issue. One thought was that the path listed in mine (/web/) might not work because the WP directory (web) is a subdirectory of a much longer path. What do you think?

    Finally got the admin on the server to allow my .htaccess to rewrite URLs. Now, however, I get a 403 error on every page load.

    Argh.

    Resolved! All of the issues were related to Apache settings by the site admin.

    What Apache settings did you change? I am getting the errors.

    Thanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Super Admin can’t create Sites (might be related to .htaccess)’ is closed to new replies.
Skip to toolbar