Support » Networking WordPress » Super Admin cant change user roles

  • I oversee a multisite setup for a friend with multiple woo-commerce sites.

    She has users set up as shop managers, but we’re finding they cant see certain plugins (for examples Google Maps) in order to set them up for their pages.

    So as a super-admin I went over to try and change each user from shop manager to administrator to see if that would solve the issue.

    However for the majority when I click on change role to I get this message:

    ‘Sorry, you are not allowed to give users that role’.

    I’ve tried both the top and bottom check button, both together, logging out and in… always the same. However, it doesn’t happen to all users. Of the 13 shop managers I need to change, about 4 do it no issue. The rest gets the above message.

    Any ideas which could help?

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Hi,
    Are the plugins that are not showing up on the child sites network activated by the super-admin?
    It is my understanding that networked plugins won’t be visible to admins of child sites.

    As to the issue with changing user roles, have you tried logging in as Super Admin then going to the child site admin and then users and changing the role there rather than going through the Network >> Sites path?

    Thanks for the reply.

    The plugins are all activated by super-admin. It may be that the owner has to rethink her maps strategy.

    I did try changing users through their own child site, but unfortunately ‘shop manager’ is the highest available user role.

    I’m having the same problem. Logged as super admin I can’t change user roles for some sites in my multisite installation.

    The strange is that problem does not affect all subsites 🙁

    I try to change permissions on wp_usermeta but with no success.

    Me too. Weird and infuriating. Anyone find a fix?

    • This reply was modified 1 year, 3 months ago by johnk12.

    Hi!

    Try to see your error log file. In my case, it was a database table that was corrupted.

    I restore the table in mySql and solve the problem.

    I am having the same issue. As far as I can tell it affects all sites.

    It happened after I updated a few plugins (nothing major or obviously dramatic.)

    In my case the only role that exists is Customer (I think what WooCommerce puts out). And yet, I am still able to edit most of things, and even create other super-admins!

    But things that require a reference to roles, the site doesn’t know what roles are supposed to be in there.

    It’s a problem.

    I have exactly the same issue as @chrisbeee. The only role the Superadmin can see and assign is “Customer”. Strangely the normal admins can see and assign all roles like “Subscriber” and so on. In my case this happened after Moving the site to a new host, but I can’t see anything wrong in the database or elsewhere.

    Any hints on how to solve this problem are highly appreciated!

    Head Goldfish

    (@shoelaced)

    Did anyone find a fix for this? I’m logged in as Super Admin and there is only one out of six subsites that, for whatever reason, won’t let me edit the user roles. It sounds like the same issue, where the roles are not available in the subsites themselves, and if I try to change the role in the “Sites” area I get the same error – “Sorry, you are not allowed to give users that role.” It’s only affecting one site, I’ve tried deactivating all the plugins and switching to a default theme, but nothing has worked.

    Did you all have any luck?

    tecladigital

    (@tecladigital)

    Nop. I still have that bizarre error in some sites of my network 🙁

    Head Goldfish

    (@shoelaced)

    Omg I figured it out. Holy hell.

    So I had changed the database prefix, and for some reason it updated the wp_user_roles option correctly on all sites except one.

    If you go into the Options table for the site with the issues, look for wp_x_user_roles, where “x” is the site ID number – in my case 2. “wp_” should be replaced with the correct prefix (check the options table on one of the working sites to compare). Simply rename the option with the correct prefix and you should be good to go. I changed mine to prefix_2_user_roles and now it works.

    While you’re at it, check the main usermeta table – if you see wp_2_capabilites, again it should be prefix_2_capabilities.

    Hope this helps.

    tecladigital

    (@tecladigital)

    Goldfish

    Thank you very much!! That solve my problem 🙂

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Super Admin cant change user roles’ is closed to new replies.