Support » Plugin: NextScripts: Social Networks Auto-Poster » Suggestion: Add compatibility for DCL

  • Resolved jackennils

    (@jackennilsen)


    Hello,

    I’m using this wonderful plugin for more than 2 years now and you guys never let me down, so keep up the excellent work.

    I’m also using Disqus on my sites, so fetching the comments on Facebook or Twitter and importing them into WordPress is a pretty cool feature.

    However, I’m not using the official Disqus plugin, but Disqus Conditional Load (DCL), which is an optimized version which only loads the scripts etc. if needed.

    Therefore I need to apply a very simple trick to make it compatible with SNAP. In the nxs_functions.php there’s a line of code (currently line 710), which points to Disqus’ plugin folder. So I simply changed it to the following:

    if (isset($dsq_api) && is_object($post)) { $plugins_url = str_replace( 'social-networks-auto-poster-facebook-twitter-g/', '', plugin_dir_path( __FILE__ )); require_once( $plugins_url.'disqus-conditional-load/disqus-core/export.php');

    Now it points to DCL plugin which has a different path but besides from that works absolutely similar.

    So my suggestion is, maybe you can add compatibility for DCL out of the box by not only checking the path of the official Disqus plugin, but also of DCL. A lot of people use it and I think this would be a very nice addition to SNAP.

    Thanks for reading and condidering this.

    All the best
    Nils

    https://wordpress.org/plugins/social-networks-auto-poster-facebook-twitter-g/

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Suggestion: Add compatibility for DCL’ is closed to new replies.