Support » Themes and Templates » [Suffusion] Theme Skinning options can't change

  • Hi,
    I am using Suffusion 3.6.6 and I am trying to do the following
    1) Select Visual effects
    2) Select Theme Skinning
    3) Change to Custom styles
    4) hit the “save change on this page button” (yes I see it)
    5) The changes do not happen and the browser jumps to the previous page that I happened to edit in the Visual Effects before I selected Theme Skinning.
    So for example if I started in Visual Effects ->Theme Selection changed the theme then executed steps 2 through 4 above I end up back in Visual Effects -> Theme Selection and my changes to Theme Skinning do not take effect.

    I have tried deleting the suffusion theme and re-installing but exactly the same thing happens.
    I can change other visual effects like Sizes and Margins when I hit save there things work as they should.
    Any idea what might be causing this behavior on the Theme Skinning page?


Viewing 12 replies - 1 through 12 (of 12 total)
  • Reset options for that page and try again.

    Tried reseting the page and the entire site same problem.
    Tried changing themes even deleted suffusion and re-installed it same thing. Something else in the environment that I am in is causing this but just for Theme Skinning which is most weird.

    Tried exporting the mysql database to a test site and did the appropriate things to point wordpress at the exported database. That worked on the test site but when I copied the database back to the production site in a new database I still had the problem.

    This problem seemed to have started after I upgraded to 3.6.6 if I have to I can start the site from scratch since there aren’t that many pages on the site yet. I was hoping to avoid doing that. I might install wordpress and your theme in a sub directory and see if this has something to do with my ISP’s environment.


    Well it looks like this bug is somehow ISP related. I created a subdomain in which I installed wordpress and your theme. It behaved in exactly the same manner that is can’t change theme skins but can change other visual effects. Here is the relevant information in case you are interested:

    Apache 2.2.16
    PHP version 5.2.14
    MySQL version 5.1.48-log

    Do you have previous versions of your theme handy to see if this is 3.6.6 issue?


    One thing you can try is to use the options under Introduction → Export / Import and import the settings from a test site where you are able to do the skinning to your overall site.

    Older versions are available at this site itself, simply by changing the version number in the download link. So instead of you can click to get the older version.

    Thanks. I’ll consider doing that if I run into difficulties with 3.6.5 which would require me to upgrade to 3.6.6.

    Found it and 3.6.5 does not have the problem. So this must somehow be releated to specific combination of LAMP environment of my ISP.

    I might go and look at logs to see if there is anything obvious there but I don’t have a lot of hope. I guess I will have to wait for a newer version of PHP which is probably the culprit here. Thanks for you help.


    I think a lot of people are having this problem (I tried everything possible and canĀ“t even manage this go-around way). Is there no permanent fix?

    PS – love the theme!

    I had to fall back to version 3.6.5 to get saving to work properly again. The author and I traded a few emails on this topic and found that the problem appears to be specific to versions of php. My ISP’s php version seemed be the culprit. I created a test system installed the latest version of php, WP and suffusion and my test system didn’t have the problem. I am happy with 3.6.5 and will be staying there until my ISP upgrades it’s version of PHP. Hope this helps.


    Great, thanks! Will switch to 3.6.5. Is it a matter of exporting the word I’ve done thus far in 3.6.6 and importing it in newly installed version? or should I be aware of any other traps? Thanks again, Serg

    Well, this issue seems utterly random – some people had to roll back to 3.6.3 to fix it and as Ted, it seems to work with 3.6.5. The only thing that I know for sure is that it impacts only the Theme Skinning section. One thing I could suggest is the following:

    1. Export your current options.
    2. Go to your MySQL admin (typically your ISP will provide you access to phpMyAdmin).
    3. Go to the database where you installed WP while setting it up.
    4. Open the table that is called wp_xxx_options. The xxx refers to an arbitrary number assigned by the WP installer, that may or may not have any value. In other words your table might simply be called wp_options.
    5. Delete the records where the option_name is suffusion_options and suffusion_unified_options (two different records).
    6. Try importing the exported file now

    Let me know if this works.

    I followed these instructions step-by-step several times — unfortunately, it did not work. I am now on an earlier version, which seems to be working fine with theme skinning– however, it does not have the flexibility of the newer version in terms of theme skinning, particularly in modifying the pre-existing skins. I think I will just have to get my hands dirty and do what I want by hand. Thanks though!

    Hi, I have the same problem and was wondering wether wichess or anybody else got it to work?


    One of Suffusion’s users was able to hunt this down:

    As mentioned there, you might need to tweak your Suhosin settings in PHP. I am working on reducing the number of options in the Theme Skinning page, but for now please try the suggested fix.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Suffusion] Theme Skinning options can't change’ is closed to new replies.