WordPress.org

Support

Support » Themes and Templates » Suffusion custom template: problems on Facebook

Suffusion custom template: problems on Facebook

  • Hello,
    My client’s website is up and running (www.tuscialets.co.uk) but when she promotes it on Facebook, the image of the front page automatically generated by Facebook doesn’t look right. It follows this format:

    Feature image
    Title and web address
    [suffusion-widgets id=’1′] [suffusion-widgets id=’2′] [suffusion-widgets id=’3′] [suffusion-widgets id=’4′] [suffusion-widgets id=’5′] [suffusion-widgets id=’6′]

    Is there any way to get stop Facebook from including the suffusion-widgets or forcing it to display the actual content rather than just the code for including the widgets in the page?

    I can’t find any posts on this subject but I can’t be the only one using a custom template and trying to promote the website on Facebook.

    Many thanks in advance for your help.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Did you try filling in content for your tag line (site description)? When I do a view source on the web site, I see this meta tag:

    <meta property="og:description" content="[suffusion-widgets id='1'] [suffusion-widgets id='2'] [suffusion-widgets id='3'] [suffusion-widgets id='4'] [suffusion-widgets id='5'] [suffusion-widgets id='6']" />

    The og properties are for Facebook’s Open Graph protocol, and you can read a description here. For og:description, usually most themes put the contents of the tag line in there, which is why I’m wondering if your tag line has any content. This is what Facebook will use as the description for the site.

    Hi, thanks very much for getting back to me.

    I have now filled in all the social media sections for the site over all and the homepage. I’m using Yoast SEO plugin and suffusion’s own SEO settings. I had left out suffusion’s own settings in favour of the plugin but they are both complete now.

    Sadly though, I still get the same issue with Facebook…

    Yeah, I actually see two og:description tags:

    <meta property="og:description" content="A website offering luxury accommodation and information about the Tuscia area of Northern Lazio, Italy." />
    ...
    <meta property="og:description" content="[suffusion-widgets id='1'] [suffusion-widgets id='2'] [suffusion-widgets id='3'] [suffusion-widgets id='4'] [suffusion-widgets id='5'] [suffusion-widgets id='6']" />

    I can’t tell what is putting out the second set, whether it’s the theme or a plugin. I suppose you can try disabling all of your plugins temporarily, then doing a view source to see if the second one disappears. If it does, then you can start narrowing down which plugin is causing the problem. If it doesn’t, then you’ll know it’s a theme problem.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Suffusion custom template: problems on Facebook’ is closed to new replies.