Support » Installing WordPress » sufficient permissions

  • When I upgraded from 2.0 > 2.0.1 I got the issue of “You do not have sufficient permission” on the admin pages. The dashboard worked, but past that, nothing. The issues listed here ( sum it up and it has no solutoin. When I saw 2.0.2 was released a few days I thought the issue would be resolved after the upgrade. No luck. Any ideas or similar issues? Thanks.

Viewing 6 replies - 1 through 6 (of 6 total)
  • There are a number of proposed solutions there ( ). Did you try all of the them?

    I’ve tried those solutions, and it is not fixing my problem. I still get just the dashboard, and when I try to do anything, including viewing my own profile, I get ‘You do not have sufficient permissions to access this page.”

    I also get this, and don’t know how to fix it. alsdkfjslk!!

    This is what the admin panel is looking like:

    If you go directly to a page, such as themes.php or something, it tells you “you do not have sufficient permissions to access this page.”

    All I did was upgrade exactly how it says.


    I went into my cpanel, into the MYSQL database with PHPMyAdmin, into the usermetadata section [pardon my stupidness, I don’t understand mysql in the least]. There were all of my users.

    For userid 1 [the admin account, obviously], it said this:


    and I changed it to this:


    VIOLA! problem solved.

    I have exactly the same problem with trying to upgrade WP locally using MAMP. I tried melilyn’s suggestion but when I open up phpMyAdmin in MAMP I haven’t a clue what I’m looking at. Any help much appreciated.



    I’ve got the same problem but my usermetadata admistrator account is set correctly. HELP!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘sufficient permissions’ is closed to new replies.