Support » Plugin: WooCommerce PDF Invoices & Packing Slips » Suddenly very slow to generate packing slips

  • Resolved jlev00

    (@jlev00)


    Hi – I’m not sure exactly when it started happening but recently it is *extremely* slow to generate a packing slip PDF. Takes about 5-6 minutes.

    I’m wondering whether it could be due to it trying to download the custom Asian font each time.

    I thought it may have been because I have been running in legacy mode with a custom template from about three years ago so I re-wrote the template based on the latest Simple but still having this issue.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Ewout

    (@pomegranate)

    How exactly are you importing the Asian font? Have you enabled font subsetting in the settings?

    Thread Starter jlev00

    (@jlev00)

    Hi Ewout – thank you for your reply.

    I import with these two lines in style.css:

    @font-face {
    	font-family: 'NotoSansJP';
    	font-style: normal;
    	font-weight: normal;
    	src: url('https://mywebsite.com/wp-content/themes/theme-child/woocommerce/pdf/nohinsho/fonts/NotoSansJP-Regular.ttf') format('truetype');
    }
    
    @font-face {
    	font-family: 'NotoSansJP';
    	font-style: normal;
    	font-weight: bold;
    	src: url('https://mywebsite.com/wp-content/themes/theme-child/woocommerce/pdf/nohinsho/fonts/NotoSansJP-Bold.ttf') format('truetype'); 

    Then

    font-family: 'NotoSansJP';

    in body.

    I tried the “font subsetting” setting but it threw an error. I’m going to try again now with all caching/minimisation turned off.

    Thread Starter jlev00

    (@jlev00)

    Actually…

    I just saw your recent update. Updated to 2.4.2 and it seems to have resolved!

    Still doing some testing but I’ll mark as resolved for now – thank you!

    Plugin Author Ewout

    (@pomegranate)

    Glad to hear it’s resolved! I can’t think of what fixed the issue in this update though.
    I strongly recommend changing the https://mywebsite.com/wp-content/ to a server path, because otherwise it’s loading it as an external source (over the internet) even though it’s on the same server – that will definitely slow things down. Our documentation explains how you can do this: Using custom fonts

    Thread Starter jlev00

    (@jlev00)

    Thank you! I have updated the path as you suggested – much quicker!!

    Thread Starter jlev00

    (@jlev00)

    …and I still don’t know what the root cause was. Maybe upgrade to 2.4.1 didn’t go well on my side? Really not sure.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Suddenly very slow to generate packing slips’ is closed to new replies.