Support » Plugin: Duplicator » Suddenly unable to build packages

  • Resolved davidkneale

    (@davidkneale)


    When I’m trying to create a new package, I’m getting the following error:
    Server Status: 200 -OK
    Error Message:

    Build Folder: /home/content/b/h/u/bhutantravel/html/wp-snapshots/tmp
    Some servers close connections quickly; yet the build can continue to run in the background. To validate if a build is still running; open the ‘tmp’ folder above and see if the archive file is growing in size. If it is not then your server has strict timeout constraints. Please visit the support page for additional resources.

    I’ve changed the wp-snapshots folder permissions to 777 with no effect. I also selected Attempt network keep alive.

    I’ve used this previously with no issue, except that the OS for the server for this site is now Linux. It is running PHP version 5.2.17.

    Any help much appreciated as I really like this plugin and would like to use to transfer sites in the future. Thanks!

    https://wordpress.org/plugins/duplicator/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Cory Lamle

    (@corylamleorg)

    Hey David,

    Checkout this section on the FAQs I believe it may help with this issue:
    -> Browse to: http://lifeinthegrid.com/duplicator-faq
    -> Find section: “3. Troubleshoot=> Timeout Issues”

    Hope that helps!

    Hi, I saw this and this is the error that I’m getting. so I shall get back to my host and see if we can increase the time allowed before I open a ticket with you.

    Thanks Buko.

    Plugin Author Cory Lamle

    (@corylamleorg)

    You can also add directory filters and enable mysqldump from the settings page on some systems, if you host has strict throttling…

    Thanks for the response. Just waiting to hear back from the host… unfortunately it’s Godaddy so I don’t have much hope.

    Plugin Author Cory Lamle

    (@corylamleorg)

    The plugin at this point in its development isn’t that great with large sites on shared hosts… Hopefully in the future these issues will get ironed out…

    Cheers~

    I finally ended up calling Godaddy and they uploaded the following php5.ini into the directory:
    file_uploads = On
    post_max_size = 200M
    upload_max_filesize = 200M
    max_execution_time = 120

    Unfortunately this didn’t work. Then in Settings I selected ‘Use mysql dump’ and now it appears to be working. I’m not sure if it was just this setting or a combination of both.

    Hopefully the site is all archived correctly. Much relieved as this is a great plugin and great for transferring sites.
    Cheers

    Plugin Author Cory Lamle

    (@corylamleorg)

    Hey David,

    It could have been a combination of both. The problem with most budget hosting is that the servers are very throttled and your at the mercy of other web-sites eating into any performance you might need for your processes… For budget hosts I normally suggest trying to create filters and then manually move any larger files…

    Cheers~

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Suddenly unable to build packages’ is closed to new replies.