WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Suddenly, header image upload not working

[Resolved] Suddenly, header image upload not working

  • I’m using Twenty Ten. Have uploaded header images several times over the six weeks I’ve been working on my blog using this theme. But today, when uploading a new header image file (.png at 940×198…the exact dimensions specified for the header for this theme) I:
    ->clicked browse to select the file…okay
    ->clicked upload
    ->Firefox 3.6.13 indicated it’s uploading but returns a relatively blank page with just the left hand menu bar (Dashboard, Posts, Media, etc.).

    This same thing happens to me when creating blog posts and seems to occur if I’ve saved and previewed the file too many times. I’ve been able to resolve the individual post problem by copying and pasting the content of the post into a fresh post window and then deleting the original. But I don’t know how to workaround the issue with the header image not uploading.

    Thanks for any suggestions.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Moderator t-p

    @t-p

    @rvoodoo answered it. 🙂

    well the standard things to try first off are deactivating all plugins and testing your site. If the problem goes away, reactivate one by one and test.

    After that, its switch to the twentyten theme and test

    I turned off my one active plugin and continue to experience the same issue when attempting to upload a new header image. The file does successfully upload to my Media folder. But doesn’t embed into the header file.

    I’m using the TwentyTen theme so not sure what else to try. Any other suggestions for troubleshooting?

    My site address is http://www.marymaru.com if that helps.

    Moderator t-p

    @t-p

    tried both in FF and IE8, your header image seems to display fine for me.

    Thanks for checking, t-p. But the problem is I’m trying to upload a new header image to replace what’s there now and am not able to complete the process.

    Under the Appearance/Header menu I’m able to browse for the new image on my computer. But when I click on Upload, I’m given a blank screen instead of the confirmation screen to complete the File Upload process.

    I turned off the one plugin I use and tried again but got the same results. And am using the twentyten theme so not sure what else I can try to resolve this problem.

    Moderator t-p

    @t-p

    – have you added the new images to your theme’s functions.php:

    for example, look for:

    // Default custom headers packaged with the theme. %s is a placeholder for the theme template directory URI.
    	register_default_headers( array(
    		'berries' => array(
    			'url' => '%s/images/headers/berries.jpg',
    			'thumbnail_url' => '%s/images/headers/berries-thumbnail.jpg',
    			/* translators: header image description */
    			'description' => __( 'Berries', 'twentyten' )
    		),

    No, I haven’t added my new header image to functions.php. I haven’t had to do that before since uploading a new header image was an automated process using the Appearance/Header menu.

    I took a look at the functions.php file and all the headers listed are the default ones included with twentyten. So my current custom header…the one that’s displayed on my blog page now…is not included in the functions.php file and yet displays just fine (and obviously uploaded okay a couple of weeks ago).

    I’m not that familiar with php. But if I have to start playing around with the functions.php file to get my new header image to upload properly…that’s fine. I just don’t know where to include the new image info. Do I simply copy this?:

    ‘berries’ => array(
    ‘url’ => ‘%s/images/headers/berries.jpg’,
    ‘thumbnail_url’ => ‘%s/images/headers/berries-thumbnail.jpg’,
    /* translators: header image description */
    ‘description’ => __( ‘Berries’, ‘twentyten’ )

    …and then replace all reference to ‘berries’ with my new header image file name? Is it correct to upload the new header image to my Media folder? Or does it need to be copied someplace else so the functions.php file can find it?

    you shouldn’t need to edit the functions.php at all, that is for adding in new default images to choose from

    the uploader should work, I wonder if you run out of memory….

    first you can try to reinstall WP core files (thats as simple as going to the upgrade menu and rerunning the upgrade, it just reinstalls core files)

    after that, there are a few posts around here about options for raising memory

    Problem solved! I searched this site for tips on how to increase memory. The step-by-steps I found didn’t work for me so I called my web host.

    They advised me to create a new .htaccess file using this code:

    AddType x-mapp-php5 .php .php4

    So I created the file in my text editor, added just that one line of code, saved the filed as .htaccess and uploaded the file to the subdirectory of my blog site. Everything is working fine now.

    Thanks for the suggestions.

    Excellent! Glad you were able to get through it!

    I had the same problem also don’t know enough about php or the technical stuff to resolve this properly, but I found an easy way of achieving the same result. Upload your custom banner to public_html/blog/wp-content/themes/2010-weaver/images/headers on your server; delete one of the pre-installed banners that come with 2010; and give the name of that banner to your custome image. Then simply click on the thumbnail of the image you have replaced on the appearance/header menu and click save. Your image should appear on the blog.

    Hello peoples!I need your advice or help.I can not upload my image.After
    “Browse..” from my computer,i cliking “upload”.Then no result,only appearing this “Missing a temporary folder”.What the temp. folder?
    What i have to do?
    Thanks.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] Suddenly, header image upload not working’ is closed to new replies.
Skip to toolbar