Support » Fixing WordPress » Suddenly for no apparent reason, can’t upload or add photos to a post

  • Resolved cnymike


    I had been using WP v2.1 with no real issues. Two weeks ago I made a new post which included uploading 8 photos and successfully inserted them into the post no problem.

    Today, I attempted to create a new post and was able to, but when attempting to upload some images, they seemed to upload (didn’t get any errors), but there was no Browse button displayed in the post window, only a Browse Now and Upload button. And when I clicked in “Browse Now”, the image I thought I had just uploaded did not appear. I Checked the uploads directory and indeed, there was no new image there.

    So I then tried to edit a prior post and in the edit window, suddenly the Upload, Browse and Browse All buttons are there. But I still can’t upload successfully anymore.

    So I decided to upgrade to 2.2.1 and the same problem exists after the upgrade.

    Any clue as to what the heck is going on? Is there some chance that my webhost might have changed something on the server that could cause this? I’m totally lost at the moment.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hosts have the tendency to upgrade software and hardware without warning their clients… but that would affect the whole blog, I guess, not only newer posts.
    I am pretty much clueless, too – can’t recall anything similar posted 🙁

    This is getting even more mysterious.

    I have another WP v2.1 blog on a different server which I had added to on June 15. I just tried to make a new post there with the same result. I was unable to upload photos successfully even though no error was displayed.

    Now both my blogs are dead in the water and I have not done anything to them since my last successful post on them. I can add an entry, but I can’t upload images anymore.

    OK…on my account I just installed into a test directory, a brand new installation of WP 2.2 using fantastico.

    I was not able to upload photos into that either.

    Two entirely different hosts… three different installations of WP including one brand new installation… and I can’t upload photos into -any- of them. I’ve tried using two different computers too, a Mac desktop and a PC notebook. I even reset my router and cablemodem thinking it might be some weird firewall thing or something. Still no dice. HELP.

    You mean the upload button/portion of the admin panel doesn’t even appear on any of them or just not able to upload?

    Whoa Nelly! I solved the mystery.

    I had written into my .htaccess file a permanent redirect for my domains… ie: permanently redirected to

    Of course I had neglected to check the WP Options to make sure the correct domain was being specified and I found that I had specified instead of

    Problem solved!


Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Suddenly for no apparent reason, can’t upload or add photos to a post’ is closed to new replies.