Support » Plugin: WordPress Related Posts » suddenly error 500

  • Resolved DinaG


    Hi, I had WordPress Related Posts working, and now they are not working. The thumbnails are showing fine, however when you click one it brings up a server error 500. I did reinstall v2.7 to check if it was a version issue.

    I guess I need to pick with up with my host, any other suggestions?
    I have deactivated it in the meantime.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Hey Dina, sorry for the late reply!

    Hm, yes, this is weird! Correct me if I’m mistaken, but after clicking on one of your related posts, you get the 500 error? Does this only happen when you click on the thumbnail part of the related post or is it irrelevant?

    Since we haven’t heard about any similar problems like yours before, we would definitely like to find out more about it. Any chance you could contact your host for more info? Or maybe send us the link to the blog in question (and activate the plugin), so we could test it out on our end as well?

    Let us know, we’re here to help! Take care & have a nice day!


    Also — any chance you could send us the error message from the host provider?


    Hi Silvo

    I have reactivated the plugin so if you go to any post, scroll down to the related posts and click a thumbnail, you will see the server error 500.

    Originally I had everything working fine on my previous url, we then set up separate hosting (same provider Netregistry) and new url and copied the blog over. Then this error started.

    I have deactivated, un-installed, reinstalled, tried an earlier version and so on .. nothing fixed it. I have logged a ticket with the host but so far they cant find the problem either.


    the error says:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    Also I have checked and nothing is showing in the server error log at all.

    Hey Dina, big thanks for all information provided, much appreciated, although we could not help us solving your problem.

    Wa can only assume something went when migrating your blog to a new domain. We would also suggest that you contact their administrator (server provider) for further help. Ask them to change the permissions for your error log, or something similar.

    This error is often caused by misconfigured permissions, as far as we could Google it.

    But do let us know how it goes, we don’t exclude the option something could be our fault as well (although we’re hoping otherwise).

    Take care & I’m looking forward to your reply!


    Hi Silvo

    My host company has come back with the following investigation:

    Seems that error below could be caused by one of the plugins.


    [Tue Jul 30 20:05:45 2013] [error] [client] PHP Notice: Trying to get property of non-object in /home/thth3970/public_html/wp-includes/post-template.php on line 29
    [Tue Jul 30 20:05:45 2013] [error] [client] PHP Notice: Trying to get property of non-object in /home/thth3970/public_html/wp-content/plugins/sexybookmarks/sexy-bookmarks.php on line 676
    [Tue Jul 30 20:05:45 2013] [error] [client] PHP Notice: Trying to get property of non-object in /home/thth3970/public_html/wp-includes/post-template.php on line 29

    It looks like the $args passed to the function is not an object for some reason.

    They have referred it back to the plugin… so no solution yet.


    Hey Dina, sorry for the late reply, but have you tried to disable that “Sexy Bookmarks” plugin as well? Seems that this one is causing you these errors, but it puzzles us why our plugin is affected in the first place.

    Let us know, we’re eager to find out! Thanks & have a nice rest of the day!


    Hiya Silvo

    I had tried deactivating the Sexy Bookmarks but nothing changed, however I did persist with the hosting provider and guess what .. they fixed it! This was their response ..

    I have changed your PHP version from PHP 5.3 to native (server default version 5.3) through PHP Version Selector on the server.

    cheers and thanks for your replies.

    Hey, that’s great news, glad to hear that as well, really! 🙂

    As always — if you have any questions or if you stumble upon any problems (let’s hope not though!), do not hesitate to let me know! I’ll gladly help!

    Take care & have a nice day!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘suddenly error 500’ is closed to new replies.