Support » Fixing WordPress » suddenly cannot upload pictures

  • i am trying to upload pics, and cannot. getting error message. the file size is well under accepted size limit. i was able to successfully upload pictures as of two days ago.

    i am using a mac, but following the instructions for setting permission for the uploads folder (currently set to 755 for the uploads folder and the folders inside it)

    my site is hosted on go daddy.

    nothing has changed in the last two days.

    i deactivated all my plugins and the pictures still does not upload properly

    i could really use some help as i need to update the site asap.

    thank you very much in advance!

Viewing 15 replies - 1 through 15 (of 15 total)
  • Moderator t-p

    (@t-p)

    i deactivated all my plugins and the pictures still does not upload properly

    Also try:

    – switching to the unedited default Twenty Fifteen theme for a moment using the WP dashboard to rule out any theme-specific issue (theme functions can interfere like plugins).
    – If that does not resolve the issue, try resetting the plugins foldervia FTP or SFTP or whatever file management application your host provides. Sometimes, an apparently inactive plugin can still cause problems.
    – also, check your uploads path in Dashboard > Settings > Media, make sure it’s not pointing to a different path . . . normally this would be blank.

    i’m sorry, how do i switch to the unedited version of twenty fifteen? and if i do this, will i lose all of my customizations?

    and there is no path under dashboard>settings>media. just allowable file sizes.

    sorry, i need a bit of hand holding here.

    Moderator t-p

    (@t-p)

    how do i switch to the unedited version of twenty fifteen?

    – If you can login, via dashboard: http://codex.wordpress.org/Using_Themes

    and if i do this, will i lose all of my customizations?

    – No.

    If you haven’t already done, always backup everything (including your database) before doing any actions, just in case something really goes wrong.

    again, i’m sorry, i think this might be above my head a bit, i still don’t understand how to swtich to the unedited version, i have twenty fifteen enabled, i don’t know how to turn the customizations off.

    i can try changing to twenty fourteen, but i’m not sure that resolves anything.

    i read the “using themes” page, but did not find anything about turning off customizations, unless you’re saying just go into the customizations tab and turn everything off, which i could do.

    please let me know

    thanks!

    @chnacat

    ducmt2908 seems to be in the habit of posting brief advice points and including a link to a website; these are being moderated as spam. Best ignore.

    What @tara is suggesting is to switch to an unedited theme to make sure that your current theme is not causing the problem. If your current theme is Twenty Fifteen, then switch to Twenty Fourteen and try the uploads while that theme is activated. This is a troubleshooting process to rule out any theme related issue, and your customisations will not be affected.

    ah, ok, thank you, i will try this now.

    ok, i changed the them, and deactivated all plugins, now it’s uploading a blank image, no picutre

    thoughts?

    aaaaand, now all of my images are showing as blank white boxes. everything i uploaded in the past week, so my site is basically completely borked.

    So with the new theme and all the plugins deactivated, the upload issue still remains. Are you able to reactivate your original theme and plugins?

    i was able to re-activate my original theme, and plugins, but i lost all my images. i just was able to restore them from a backup and they seem to be there, but i cannot upload any new images.

    Seems odd. What exactly is the error message you see when you try and upload an image? Also, if you have access to a cPanel, you can check your error logs there are see if anything is listed of interest.

    well, now i’m not getting an error, but the upload just seems to fail. i get a white box with a little geometric colored shape in the middle (the placeholder for a picture) but no actual image.

    i just tried the upload again, (after restoring from a backup) and miraculously, now it is working…

    lemme see if it actually worked.

    OH MY GOD… now it’s working! i have no idea why it was not before. same plug-ins, same theme.

    the only thing i can think of is that the media files were corrupt and the restore from a backup might have fixed them?????

    Hey. That’s great news. Your diagnosis could be correct. Important thing is that you are back up and running again. And it just goes to show how valuable those backups really are for any website admin in times of glitches in the matrix. Cheers!

    thanks!!!! and thanks for your help, you definitely helped me troubleshoot and i appreciate it a lot!!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘suddenly cannot upload pictures’ is closed to new replies.