Support » Plugin: WooCommerce Grid / List toggle » Suddenly broken – issue with WooCommerce CSS?

  • Resolved James


    Hi James,

    Hope you can help. The grid/list view plugin has been working great, but suddenly noticed today that it is broken and I can’t figure out why. Could you help please?

    The problem I have is that the list view setting does not seem to work; the product list fades in and out when you click between the list and view options, but there is no change of the layout (just seems to stay as grid view).

    Also the grid and list view option buttons are not displaying correctly – there is just the text and symbols, but no actual buttons surrounding them.

    The plugin seems to be half working as the product list does fade in and out as I mentioned already, and also because the product description is shown in grid view (which it isn’t by default in my theme (Striking) without the plugin).

    I have tried deactivating all WooCommerce related plugins to check for conflicts, but this didn’t help. However if I deselect “Enable WooCommerce CSS” in the WC general options page then the plugin seems to work fine again (but the formatting of the shop pages is obviously not very pretty). Re-enable WC css and the plugin breaks again.

    I have tried reverting to the default WC css pages (woocommerce-base.less and woocommerce.css) to see if it was some of my customisations that were breaking things, but other than reverting to the default colours this didn’t do anything.

    My website is here if you could take a look:

    Any ideas please???

    Cheers, James 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • Ok, some further investigations and this seems to be an issue with W3TC caching plugin. The grid / list toggle plugin now seems to break when the ‘css minify enable’ option is turned on in W3TC.

    I’ve tried all combinations of settings I can find / think of in W3TC with regards to the css side, but whenever css minification is turned on in any form them the grid / toggle plugin breaks as described above.

    I’m fairly sure that this is a new problem with the latest updates of one or other of the plugins as I have never noticed the issue before today, so it must have started in the last week or so.

    So any thoughts please James?

    Hi James,

    I notice your post is 5 months old now but thought I’d share my solution in case you are still trying to resolve, or in case anyone else has the issue. I had the exact same problem with W3tc and the grid/toggle woocommerce plugin.
    The issue is with the js minification.
    I found that is I manually added all the .js scripts but omitted the ones that caused the issue then it all seems to work again.
    The scripts that were causing the issue for me were:

    I hope this is useful to help anyone else with this issue.
    I was keen to keep my list view so that I could have short item descriptions on display to help showcase my products:

    To add to the above – I also noticed I needed to tell minify to ignore the following:
    Otherwise my add to cart button disappears!



    @middmeister – cheers, only just seen your reply. I solved the problem in the end by turning off minification in W3TC and using the CloudFlare service instead. This seems to have solved nearly all caching issues of this sort for me (I think!).

    Cheers, James

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Suddenly broken – issue with WooCommerce CSS?’ is closed to new replies.