sudden disappear of visual editor (80 posts)

  1. aramiz
    Posted 8 years ago #

    hi there!
    i've had this problem too few days ago.
    i've found that the problem was with the "Site Unavailable" plugin.
    if you activate it be aware that this problem can happen to you.
    i hope a new wordpress version cames with this problem solved.

  2. aequalsb
    Posted 8 years ago #

    re: missing visual editor (RTE) and example url: http://demo.opensourcecms.com/wordpress

    it looks like this problem could be caused by bad added code...

    on reviewing the site above, the first thing i promptly noticed is added content (ad banner at the top and other content elsewhere) that appears in the admin interface (??) for what purpose i do not know (maybe abuse of this WP.org site for traffic?)

    on reviewing the source code, i noticed an immediate problem: there is code (the code that generates the ad banner) above the doctype declaration.

    in the past, i have noticed any number of wild results when content is coded before the doctype. this would be the first place i would check. it is not outside my realm of experience for something like this to break something seemingly completely disconnected.

    i suggest an install with nothing but pure unchanged WP files and a pure unchanged default theme -- STRAIGHT out of the box with no plugins. if you can see the RTE, then it should be safe to assume that the poorly structured content is the root of this problem.

    additionally, i can confirm that certain plugins using JavaScript can break the visual editor. i experienced this with the alpha release of NextGen Gallery (pretty good plugin for an alpha release!). i also read elsewhere of other plugins causing the same problem.

    i fixed the NextGen conflict by following a less-than-explicit suggestion i found in the NextGen forums: without upgrading from 2.1 to 2.2, i merely downloaded the 2.2 install and unpacked the .zip file -- then i grabbed the tinymce folder and uploaded it to the server (overwriting the existing one). now NextGen and the visual editor work together without a full upgrade (yet).

    a client of mine, a very good programmer, once said to me when i was trying to blame his server for causing a simple PHP mail script of mine to malfunction: "99% of the time the problem is in YOUR code." looking at my code again with an open mind, i found that he was right. i fixed the code and everything worked. now, every time i face any puzzling errors during development, i say to myself "Look to your code!" that open-minded philosophy has served me well again and again.

    i believe most of the serious issues surrounding the visual editor can be explained by bad code -- content, plugins, or poorly structured customizations. and it is NOT up to WordPress to solve other people's bad code. so, no waiting for WordPress to release a new version that will hopefully fix a plugin conflict... the wait should be with the plugin developer.

  3. units
    Posted 8 years ago #

    I'm utterly confused, I've tried just about everything suggested here, to no avail. I've installed this locally on an Ubuntu 7.04 install with PHP 5.2.1, with WP 2.2, and the Visual Editor just isn't appearing, nor am I able to add new categories from the post-new.php (Write Post) page, though I can see the option to use the Visual Editor from the My Profile page.

    Now, the weirdest part is that I've _already got a working install of the same version of WP working side-by-side_. That is, I've got two installs of WP in two different directories, using the same database (with different table prefixes, obviously), so I know it's not a javascript-being-blocked issue. I'm completely stumped why the Visual Editor works great on one and doesn't appear on the other.

  4. aequalsb
    Posted 8 years ago #


    is the installation in question a raw, "straight-from-the-box" installation? if it is a 100% completely unmodified WP install, then you have a real mystery. otherwise, if you have made ANY modifications, you might want to systematically check each and every modification.

    a javascript added by you or a plugin that uses javascript can break the visual editor's javascripts (or any other javascript for that matter).

    try a brand new, "unshared" database with a fresh and 100% clean install of WP (to eliminate as many loose ends as possible). if the RTE works, you know that your installs have been altered in some way to break the editor. i can assert that the visual editor from versions 2.0/2.1/2.2 work fine with several types of installs for various clients -- even with heavy customizations and/or plugin addons (some requiring workarounds as noted in my post above).

    the OS and PHP versions you provided are not relevant information in this situation, as javascript for the RTE is handled by the browser on the client-side. of course, the content is put together on the server-side, so badly formed content may break the javascript when it gets to the client-side.

    remember, and i assert this for anyone's sake, there are only two places to look to find the solution.
    [1] the browser itself
    ...is it a javascript-capable browser and is javascript enabled?

    [2] the code
    ...any added content or plugins can indirectly or directly break the javascript necessary for the RTE to work -- although you can almost count on the fact that any modifications that do break the RTE's javascript will themselves use javascript.

    answer this question: "what content or plugin have i added that uses javascript?" from the lineup that results from answering that question, you will likely find the culprit. note: ANY plugin should be a suspect in your lineup -- it's possible some plugins use javascript even if you think they don't.

    hope this helps...

  5. rschumaker
    Posted 8 years ago #

    Thanks Tieguy - the check book on the user page did the trick for me.

  6. mydavisfamily
    Posted 8 years ago #

    I know this is not a permanent solution, but every time I lose rich text edit I check the SQL table wp_usermeta and find the rich_editing meta_value has been changed from true to false. I change it back to true and resave the record. Don't know why it's happening but it seems to change it for a number of users when it does happen.. I have to change them all back to true. Since as the admin I can only see the RTE checkbox for myself, and not for other users, I have to periodically check the D/B as the users get confused when they don't get the RTE tab and only see code. Hope they allow admin's to see everone's RET box on an upgrade.

  7. zedd138
    Posted 8 years ago #

    I'd just like to say thanks, various comments on here helped me solve this problem. :-)

  8. gagnews
    Posted 8 years ago #

    I cant seem to eliminate this issue. My database is fine, my code seems fine, all I can see regarding errors is this one that appears only in IE7.

    Error:'realTinyMCE'is undefined
    URL:post url is here

    Can someone shed some light?

  9. eiainlennon
    Posted 8 years ago #

    I have the same problem with the visual editor vanishing. However, if I use my laptop to access my wordpress the visual editor is there, I am using Vista Business, but on my PC using XP Pro - nothing there!

    Even odder - from the same pc my partners visual editor is there, and mine not - so not exactly a browser problem. I think it is the way the isntallation is controlling the browser, just dont have a clue as to how to fix it.

  10. ethanol76
    Posted 8 years ago #

    After some debuggings with Firebug I saw that my new install had some HTTP 500 errors:

    • wp-include/js/tinymce/tiny_mce_gzip.php and
    • wp-include/js/tinymce/tiny_mce_config.php

    Chmod-ding (775) the two files resoved the problem for me (wp version 2.2.2).

  11. mydavisfamily
    Posted 8 years ago #

    I believe I have found a permanent solution for the problem of vanishing rich_editing flags for some/most of us with a couple of very minor changes to two of the WP core programs (admin-functions.php and user-edit.php).

    Many of us have been plagued for some time with the vanishing rich_editing flag. User's contacting me said they were seeing a bunch of strange characters when they would try to post. Checking I would invariably see that their rich_editing had been changed to false. After resetting it to true, I would get another call with the same problem. I reached my frustration level early and decided to do a little snooping.

    I discovered that anytime an administrator attempts to change a users profile, any setting, on the Change User screen, the user's rich editing flag turns false. Making a change to your own profile this problem does not occur.

    Since I'm pretty much of a newbie with PHP, I don't know exactly why it happens but I think it has something to do with the users rich edit flag not being captured along with the rest of his data prior to re-updating his wp-usermeta records (change #1 below).

    These minor changes not only clear up the vanishing rich-edit for me, but also give the administrator the option now to turn rich_editing on or off for users from the edit-users screen (change #2 below) instead of having to access the SQL data bases for this.

    Since so many have had this problem, and if this fix solves the problem for enough people, it just might be important enough for the WP moderaters to take note and review it's feasibility and workability for inclusion in a future upgrade as each time you upgrade to a newer version you would need to propagate these patches to the new version each time.

    I sure hope this helps someone. It does work for me. If it is helpful, I would appreciate a reply here.

    Change #1: Modify the admin/admin-functions.php/get_user_to_edit function:

    after line #428:
    $user->jabber = attribute_escape($user->jabber);

    Add a new line:
    $user->rich_editing = attribute_escape($user->rich_editing);

    Change #2: Modify admin/user-edit.php.

    Insert between:

    <fieldset> (around line 86)
    <legend><?php _e('Name'); ?></legend> (around line 92)

    The Following:

    <?php if ( rich_edit_exists() ) : // don't bother showing the option if the editor has been removed ?>
    <p><label for="rich_editing"><input name="rich_editing" type="checkbox" id="rich_editing" value="true" <?php checked('true', "$profileuser->rich_editing"); ?> />
    <?php _e('Use the visual editor when writing') ?></label><p>
    <?php endif; ?>


    Disclaimer: Line #'s mentioned here are valid for v.2.1.2 but may be different for other versions of WP.
    If you do cut/paste of these instructions, I'm not sure if they will copy correctly. You need to check.

  12. zszalbot
    Posted 8 years ago #

    I had the same problem. I can be solved but you need php5. I never found why php4.4.7 could not work with it but having upgraded to php5 I no longer have this issues. Do try.

    zbigniew szalbot

  13. Darran
    Posted 8 years ago #

    I just tried using the visual editor and I do not have this problem.

  14. mydavisfamily
    Posted 8 years ago #

    My host is running php4.4.7....
    I guess I will have to wait for them to upgrade..
    If nothing else came of it, I'm still glad I can change the visual editor for members.

  15. skippysandy
    Posted 8 years ago #

    I actually had this same problem once...
    what version of WordPress are you using? I was using 2.2, I'd upgraded from 2.1 and the visual editor made a disappearing act...
    I'm no expert, so I just decided I'd have to live without it. I tried re-uploading the original data, all sorts of things...
    I fixed the problem by un-checking the 'enable visual editor' button in my dashboard. Very odd, but it worked...I don't know if it would work for you or not, but it's worth a shot, I guess.

  16. mydavisfamily
    Posted 8 years ago #

    I don't know if we are talking about the same thing here. My problem - was - that the visual editor would become "unchecked" (false) for a member whenever an admin made a change to that member's profile. That would cause the loss of the visual tab on the new post or edit post page, and the member would see all the html coding and get confused.
    This is no longer a problem ,for me, with the patch above.

  17. sobritain
    Posted 7 years ago #

    same thing also happened here..
    for those of you who get a blank page when trying to write a new post, switch to Mozilla Firefox..
    and for those of you who can't get the rich edit box, try this plugin...http://www.deanlee.cn/wordpress/fckeditor-for-wordpress-plugin/
    this should bring you more fuctions..

  18. hellveen
    Posted 7 years ago #

    This is what i did to solve this problem:

    rewrite code in tiny_mce_qzip.php to false
    reinstall wordpress
    deactivate and activate all plugins
    deactivate wp-poll plugin
    clear browser cache
    refreshing the page
    deleting tiny_mce cookies
    opening in Firefox & IE7
    re-checking "use visual editor" in my profile page
    update tinymce from official site of this function

    I can't use visual editor in any browser, after all of this hacking to decide this problem.
    Wordpress team must pay attention to this bug!
    I'm using WP 2.3.2, Firefox, Windows XP
    My screenshot http://hellveen.googlepages.com/wp.jpg
    Please, help me with solving this problem...

  19. hellveen
    Posted 7 years ago #

  20. mcruywagen
    Posted 7 years ago #

    I experienced a similar problem with the Visual Editor simply disappearing recently, and by chance managed to solve it. The culprit in my case was Kaspersky Anti-virus. By changing the Web virus scan method to "Buffering Scan", the problem was resolved and the visual editor is back in WordPress! (I was actually searching for a solution to youtube videos taking forever to display on my pc, when I came across a reference to the Kaspersky Anti-virus issue). Then I realised it might be what's causing the editor problem as well.
    Bottom line: Problem solved and I'm happy again!

Topic Closed

This topic has been closed to new replies.

About this Topic