WordPress.org

Support

Support » How-To and Troubleshooting » sudden disappear of visual editor

sudden disappear of visual editor

Viewing 15 replies - 1 through 15 (of 79 total)
  • Hey, I have the same issue. Resolved it by creating a non-admin user, as they seem to have access to use the editor. I observed that if you ever make a user admin, it’ll no longer have access to the “graphical” editor. I have no idea why this strange limit has been imposed, but it sure is annoying…

    Regards,
    Morten Skyt

    mortenskyt

    i create new user as editor and enabled the visual editor for the user now in my admin side i find that ordinary editar appear still visual editor didn’t appear

    btw :so long it’s [visual editor] working with out any problem why suddenly ?

    fresh installed also i have same above problem , well i installed in my pc it’s work well so it’s not browser problem also .

    i found recently from my havascript consol firefox

    few error

    i belive due to this i can’t get the editor

    Warning: test for equality (==) mistyped as assignment (=)?
    Source File: http://www.domain.com/wp-includes/js/prototype.js?ver=1.5.0
    Line: 125, Column: 39
    Source Code:
          if (match = source.match(pattern)) {
    Warning: anonymous function does not always return a value
    Source File: http://www.domain.com/wp-includes/js/prototype.js?ver=1.5.0
    Line: 731, Column: 2
    Source Code:
      },

    any solution

    I had same problem 🙁

    Same here!

    Cannot -for the life of me- figure out what is causing this.

    Definately not a plugin problem (disabled them all) nor a browser related issue (both IE and FF) nor a admin user thing (admin, editors and subscribers)…

    Only thing I can see is that the blog that has this problem is in a subdirectory and not the web-root:

    WordPress 2.1.1 (upgraded straight from 2.0.5)
    PHP 5.0.4
    MySQL 4.1.20
    WordPress Address (URL): http://mydomain.com/wordpress
    Blog address (URL): http://mydomain.com

    In contrast: another blog running on the same server, only another domain, doesn’t have the ritch editor problem. The only differences (beside the domain name) that I can think of are:
    1. WP is installed directly in the web-root and not a subdir…
    2. Upgrade history was different: 2.0.5 > 2.0.7 > 2.1 > 2.1.1 (not straight from 2.0.5)

    Anybody any ideas?

    I’m not sure if the problem I’m having is related to what the rest of you are describing or not. When I click on either “Write” or “Write A New Post” I just get a blank page. Not an error page, just a totally white page. I was posting fine earlier today. Is anyone else having this problem? I tried creating a new user name like someone had suggested but it didn’t help.

    Sorry tryintolearn, that is another issue… in the case discussed (or rather: reported, without any solution) here it is a Write page that loads but does not show the rich text editor (TinyMCE) like it should.

    To see it ‘in action’ go to http://demo.opensourcecms.com/wordpress , click ‘login’ and use the following info –
    login:admin
    pass:demo

    Then go to ‘Write’ and see what happens. In our case, the page loads but there is no text editing possible, just a textarea field without the rich editing options.

    If you only see a blank page there also, it might be your browser that is causing a problem?

    I’m seeing this post-upgrade too. I only have one user (the admin user) on my blog. Oddly, I didn’t see the problem until after I changed something in the admin user prefs- I did the upgrade from 2.0->2.1, used it for a week with no problems, and then added a website URL to the contact info for my admin user. Immediately after that, the visual editor disappeared (and the automatic preview-on-save too.)

    Hope that little detail helps someone clarify/fix the problem.

    [BTW, is there a bugtracker for wp? This definitely seems like a bug, and not just a support issue.]

    Ah-ha. If you just go into users->your profile, and click ‘use the visual editor when writing’, you get the visual editor back. Now, it is still a bug that this somehow gets unchecked when you edit the page, but… obviously easy to resolve once you’ve poked around a bit 🙂

    Except after what I think is the 2.11 upgrade I have lost the RTE AND the option under Your profile. The checkbox has vanished…

    YellowSwordfish

    your wp-includes is Corrupted. delete your wp-includes folder and upload freshly

    Tieguy, indeed there is a checkbox for ‘Use the visual editor when writing’ on the Users>Your Profile page… I am supposing that this is checked? If not, you should see only some quick-edit buttons above the textarea on your Write page. If checked, there should be a more extensive bar with fancy editor icons… In my case NOT 🙁 . I have no problems with the checkbox ‘unchecking’ or anything… just no RTE.

    Decided to test some more. Three test-sets:

    1. I downgraded (if you can call it that) version 2.1.1 to version 2.0.7 – disbaled all plugins and overwriting all files (except wp-config.php)… After running the upgrade process, still no RTE.

    2. Did a clean install of WP 2.0.7 complete with new database and fresh (empty) content. The RTE works like I am used to! Now upgraded that clean install of 2.0.7 to 2.1.1… RTE gone again 🙁

    3. Again a clean install of 2.0.7 (like before with the RTE working fine) and uploaded 2.0.9. Run the upgrade.php process manually because it didn’t start up automatically. RTE was still purring like a kitten :)… Then upgraded to 2.1 (upgrade process ran automatically), logged in and went to the Write page. No RTE but the conventional editor so went to Users>Your Profile and checked ‘Use the visual editor when writing’ because that setting apparantly was changed during upgrade (stange). Then went to Write page: TRE not working!!!

    4. Did a clean install of WP 2.1 with clean database: still no RTE, ofcourse…

    The strange thing is that I have another WP 2.1.1 installation running on the same server, with TRE! I’m completely at a loss here. Will revert to 2.0.9 untill this is resolved.

    I also have the problem that I cannot get the rich text editor to work (it does not show) neither on http://demo.opensourcecms.com/wordpress or on my own site. I’ve tried IE7, FF2 and to turn off my own anti-virus.

Viewing 15 replies - 1 through 15 (of 79 total)
  • The topic ‘sudden disappear of visual editor’ is closed to new replies.