Support » Fixing WordPress » Sudden comment error 144 (everything was fine)

  • Suddenly today I am getting the following error for comments. Had done nothing to the database and things were fine yesterday:

    _____________

    [Can’t open file: ‘wp_comments.MYI’ (errno: 144)]
    SELECT * FROM wp_comments WHERE comment_post_ID = ‘917’ AND ( comment_approved = ‘1’ OR ( comment_author = ‘Idyllopus’ AND comment_author_email = ‘myemailaddresshere’ AND comment_approved = ‘0’ ) ) ORDER BY comment_date
    _____________

    I’d done nothing to the database. The error just began occuring.

    Would greatly appreciate if someone could help me determining how to fix this.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Had you installed any new plugins? Installed a theme whose author might have failed to remove a plugin call? If you didn’t do any of that, and you have literally done nothing else since before that happened, I’d suggest asking your host if they’ve done something, such as “upgrade” something, or restore from an old backup after a problem….

    Generally, wordpress doesn’t arbitrarily change itself, and if you’re positive you didn’t change it, then that just about leaves your host….

    Thanks. I’d installed no plugins and hadn’t worked with the theme. Done literally nothing on the blog.

    In the meanwhile I have been searching and finally found a person with the same problem and the fix of running in PHP Admin:

    REPAIR TABLE tablename USE_FRM

    Did it and everything is back in order.

    Appreciate your response.

    I found exactly the same error on my blog. The comments table seems busy, open or unavailable. Anybody knows how to repair the table via Phpmyadmin?

    I contacted the hosting provider tech support and willreport here any news.

    My guess is a surge in comment spam or a comment exploit.

    Update: tech support repaired the mysql table and that’s it.

    > MySQL said:
    > #1016 – Can’t open file: ‘wp_comments.MYI’ (errno: 144)

    Any idea how tech support fixed it? I have the same problem now and I’m my own tech support 😉

    Easy, in fact: at the mysql prompt (or in the SQL area of PhpMyAdmin, if it lets you) type

    REPAIR TABLE wp_comments

    🙂

    I’m getting the same error and am not technically savvy (don’t you hate dolts like me? I try to learn as I go, though!).

    Can someone direct me thru this step by step? I did email my host so hopefully they can fix it but if they can’t – any help is appreciated!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Sudden comment error 144 (everything was fine)’ is closed to new replies.