Support » Plugins and Hacks » Genesis Featured Widget Amplified » [Resolved] Sudden bizarre disappearance of sidebar, footer, slider due to GFWA conflict

[Resolved] Sudden bizarre disappearance of sidebar, footer, slider due to GFWA conflict

  • Yesterday GFWA was doing its thing displaying featured posts with different tags for me on the home page of a site using the Adorable theme, and also the Genesis Responsive Slider. This morning I happened to notice that the Force Regenerate Thumbnails plugin needed updating. I’ve used that a few times because of changing slider image sizes, etc, and not had any problems with its previous incarnations. And I’ve used GFWA on more sites than I can count now and never had any trouble.

    Anyway, whether or not the two are related, I suddenly noticed a serious problem on the home page where the featured widgets were supposed to display. The slider stopped displaying. (Tried turning the slider off. Didn’t help.) Halfway down the featured widget areas, the featured widgets stopped displaying, too. No footer. No sidebar. Links below show screenshots of the layout as it’s supposed to be (with the default post widgets) and the layout broken.



    I checked to see whether I had any unclosed divs in posts, and didn’t find any. I checked the actual home.php file to see whether that had gotten corrupted, but that’s fine, too. (Also, the fact that the layout fixed itself when I turned off GFWA, but stayed broken when I turned off any and all other plugins, seemed kind of suggestive.) I am Frankly Baffled and rather anxious, as I use this plugin all the time.



Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Nick the Geek



    That is pretty weird. Is there a way for the plugin to be active on the site so i can see exactly what is happening when it is running and broken?

    I can go reactivate it.

    Plugin Author Nick the Geek



    I’m still not sure why it is happening but there appears to be a php error in the widget “Wedding Cakes” This is stopping everything from loading at that point.

    Could you please enable debug mode. This will output the error that is stopping the output. Here is a basic tutorial on that

    Site Recovery Tips and Tricks

    I know how, but this is a free site hosted by ZippyKid, so I don’t have direct access to wp-config.php. I have to ask them to turn wp_debug on. So it will take a while. But what you said made me think. I’d just created a post under wedding cakes, and also edited the tag for same. What if I attempt 1) removing that widget and creating a new one and 2) if that doesn’t work, deleting the post (which only has a featured image) and re-creating that?

    It strikes me that changing the name–and slug–of the tag is the thing most likely to have messed up the widget.

    Ha! Yes, that must have been the problem. The question is–was that my problem, or yours? Will the widget always break if someone edits the name/slug of something used for the widget? I can see how it might, and how it might not be possible to prevent.

    Plugin Author Nick the Geek



    Well, I’ve never tried to see if that will break things. I wouldn’t think it should completely break things, but I can test to see if I can recreate this and then try to find a way around it.

    What exactly changed that seems to have caused the error?

    I was adding a new post, put the tags on it, noticed that the tag was singular instead of plural. For consistency with the other tags, I thought it should be plural. So after I saved the post, I went over to the tags and edited the tag to make the tag name, and tag slug, plural. It seemed to take a long time to save that change. The tag in question had been “Wedding Cake” (changed to “Wedding Cakes”), slug “wedding-cake” (changed to “wedding-cakes”).

    That tag, of course, was the particular taxonomy selected for the GFWA widget under the heading “Wedding Cakes.”

    Now, it would make sense to me if that particular widget broke when I changed the tag name, and that would have given me a clue, given I knew I’d just changed the tag name, to go re-set the widget. What I don’t understand is why EVERYTHING ELSE then also broke.

    Is that enough info for you to repro the problem?

    Oh, BTW, the debug bar pointed some deprecated function calls: attribute_escape and get_theme_data. Might be time to fix them if you’re going to need to tune something up anyway. (I had actually fixed them myself, but then thought maybe I should re-load the original version of the plugin to see whether that would help.)

    Plugin Author Nick the Geek



    Thanks for teh detailed explanation. I’m going to try and see if I can get things to break, then figure out why it broke and come up with a good solution to prevent that from happening.

    The reason the other things broke in in a PHP fatal error the site will stop processing when the error happens. So nothing was generated after that point. That is how I was able to quickly identify which widget exactly was throwing the error even without debug. Since everything stopped there the sidebar was never loaded because the code comes later. The javascript for the slider was loaded either, because that is in the footer.

    I’ll also be fixing the other deprecation notices with the next version of the plugin.

    I can’t tell you how glad I am to know there will continue to be more versions of the plugin. I was a little concerned when I saw it hadn’t been updated since May, even though there’d been new releases of both WP and Genesis. I use it so much that I’d hate to see it disappear. (So maybe I should drop something in the donation jar, ya think?)

    Plugin Author Nick the Geek


    Well, I wouldn’t say no 😉

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] Sudden bizarre disappearance of sidebar, footer, slider due to GFWA conflict’ is closed to new replies.
Skip to toolbar