Support » Fixing WordPress » Sudden (and now consistent) 500 Internal Server Error

  • host: 1and1
    mysql: php5
    wp: 2.7.1

    Just upgraded and at the same time emptied the tables to start over with new test posts/tags/etc. Installed fine, set up plugins, re-chose theme, and then went to mess with settings. I changed date format and time format and saved; then realized needed to change WP & Blog addresses (since the dev site URL is not the same as the eventual destination). That’s when I got the 500 Internal Server, so I went back, saw the changes were undone when page reloaded, tried save… and error again.

    The fact that I was changing the URL may, or may not, be relevant. Have no idea.

    At the same time, the visible version of the site has lost all formatting — as in, the theme isn’t being loaded, nor is the style.css, and it’s just a text output.

    I tried removing the plugins, and this only threw errors because the site was looking for plugins it can’t find. I tried removing single plugins (renaming them) and that didn’t do anything (except throw errors where the template wants a plugin and can’t find it).

    I’ve been through the various threads on this kind of error, and can’t find anything that works, nor do I see anyone else mentioning their live site losing its theme/style at the same time, so I’m not sure if this is the same problem as others have had, or something else.

    Never had a single problem with the last version of WP, and the other two installs of WP I’ve got (not upgraded) are doing fine. Copied over htaccess and php.ini from other WP installs to this dev folder, and the error remains. Fiddled with both per suggestions in other threads, still got nothing (but one big error that shows up no matter where I go or what I click on).

    — php.ini:
    display_errors = On
    register_globals = Off
    memory_limit = 32M
    max_execution_time = 300

    The ‘max-execution-time’ was a suggestion for 1and1 specifically, something to do with their PHP4 and PHP5 servers having varied time-out lengths. (Not sure it’s doing anything for me, though this insertion did resolve problems in a recent drupal dev install.)

    Changing memory limit does not resolve (went all the way to 128M); adding/removing max_execution_time does not resolve. Also added/removed the following lines, to troubleshoot:

    upload_max_filesize=20 M
    post_max_size=20 M
    magic_quotes_gpc = 0
    session.auto_start = 0
    mbstring.http_input = pass
    mbstring.http_output = pass
    mbstring.encoding_translation = 0

    Some of these are copied from what I had to do to get drupal install to work, but figured might as well test them here, too. Just in case. None seemed to fix the issue.

    — htaccess:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    Also tried:
    Options All -Indexes
    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    Did that in various combinations — first line only, first and second, first and third, second and third, yeah, I was starting to get really annoyed. Current version is copied over from other WP install and again, doesn’t fix the issue.

    I am completely at my wit’s end on this one. I’ve had WP installed on at least two sites now for almost a year, and I’ve never run into something like this before. I even emptied the database a second time and did a complete reinstall, with the same htaccess and php.ini used in my current (working just fine) WP installs. Again, it let me set up the basic info, activate plugins, even upgrade several to the latest version, and then I went into settings and… error 500, all over again.

    Does anyone have any ideas, no matter how wild? At this point, I’m starting to wonder if the best choice is to just downgrade back to previous version and ignore the constant reminders to upgrade to the newest. At least I know the previous version isn’t broken. I hope… assuming this issue isn’t contagious.

Viewing 3 replies - 1 through 3 (of 3 total)
  • I should add: I also tried removing htaccess (didn’t fix), removing php.ini (didn’t fix), then removing both (didn’t fix). So… no idea.

    Went back, dropped the db, created a new one, did completely new install from ground up. Plugins, usual set up, everything was fine, until I decided to test by changing the wordpress URL: immediate error 500. I went into the db and changed it back to the dev URL, and no more error. Then I changed the blogsite URL, and the same thing happened.

    I don’t know if that makes it a bug, or what, but changing either of those URLs causes error 500s to take over the site, and for the theme to disappear.

    I am sorry that no one was able to help you with your post editing problem. But I realize that you wrote this sometime ago and your blog might be running well by now.

    I was having the same problem as you, meaning that I couldn’t edit an important post I had for about a week! But I followed your steps, and now my blog is working!!!

    Thank you very much!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Sudden (and now consistent) 500 Internal Server Error’ is closed to new replies.