Sudden 500 error, cant insert images or add posts (14 posts)

  1. goingnutz
    Posted 3 years ago #

    friday - the site is working fine, i hand it over to the client...

    1. i back up the site via Godaddy's mysql backup facility...
    2. i set up a new admin account for the client.
    3. i erase the old/original admin account/s*

    all is working well...

    over the weekend the client uploads 5 x 3000pixel wide 1.9MBsized HUUUUGE images...groan...head in hand...

    all of a sudden we cant insert any images (via the media upload flash and non flash) without getting all kinds of random messages.
    sometimes i get
    1. are you sure you want to do that?
    sometimes i get
    2. 500 internal server error
    sometimes i get.
    3. Crunching... (indefinitely...)

    The images do upload into the uploads folder but they cant be inserted into a page of post.
    the images are 0x0 in size.
    and all the thumbnails of all the other images in the media gallery take on the lastest image uploaded.

    when i try to add a new post
    i get a 500 internal server error (ISE)

    When i try to update existing posts
    i get a 500 ISE (but they still update

    Ive trieds almost everything i can find on the forums...
    - turn off plugs - doesnt work
    - try default theme - doesnt work
    - replace admin and includes folders -doesnt work
    - add all the various codes to the .htaccess file - doesnt work
    - add all the various codes to the php.ini + php5.ini files - doesnt work
    - tried to restore the main admin via myphpadmin - doesnt work
    - changed relevant folder and file permissions to 777 - doesnt work
    - tried firefox instead of safari (im on a mac) - no joy

    the only things that i think that it can be are:
    1. the database corrupted during the backup process...some strange things have happened when ive backed up sites in the past. - ive emailed GoDaddy...

    2. deleting the main/original administrator account has somehow messed up the permissions on the site - preventing me from updating the site....this is a possibility, but the site worked fine for at least 48 hours. i.e. the client uploaded the HUGE images and posted about 5 posts.

    3. the server allowance has been exhausted because soo many HUGE files were uploaded...ive emailed Godaddy to see if they can shed any light on the issue, i.e. empty a tmp folder or advise me on how to increase my allowance etc.

    anyone else got any bright ideas? id be very grateful for any suggestions above and beyond what ive mentioned above...im in the process of moving the theme folder into a fresh install of wordpress...but this is a last resort!

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  3. goingnutz
    Posted 3 years ago #

    Hi Esmi,
    thanks for taking the time to respond...ive seen you on pretty much every forum :)
    answers to your questions...

    Another strange thing i learned yesterday...
    i recreated the entire site! all was working well until i imported the xml file generated by the old version of the site. as soon as i imported that xml boom! the site wouldnt let me make any posts/upload any images etc. I deleted all the posts, commetns and pages from the site and the problem persists.
    VERY STRANGE...what could it be about the posts that could cause this problem? im stumped...ive tried almost everything i can think of.

  4. esmi
    Forum Moderator
    Posted 3 years ago #

    as soon as i imported that xml boom!

    Well that pretty much nails it down to an issue in the old site's content. Is this new site on a different server? Maybe with a new host?

  5. goingnutz
    Posted 3 years ago #

    different installation/ not a new host, i have about 10 WP sites on the server and only this one has the issue.

    The problem seemed to occur after the deletion of the main administrator (but this is often a recommended security step)

    and the upload of the HUGE files.
    Godaddy have fobbed me off with 'we cant duplicate the issue' (ha ha) which means they haven't even tried. because its there alright, its been tested by a number of people using various browsers etc etc

  6. esmi
    Forum Moderator
    Posted 3 years ago #

    The problem seemed to occur after the deletion of the main administrator

    How are you deleting the primary admin?

  7. goingnutz
    Posted 3 years ago #

    i created a new admin, logged out of the old one, then logged into the new admin and erased the old one transfer all posts etc to the new admin, all seemed to work well.

  8. esmi
    Forum Moderator
    Posted 3 years ago #

    Can you try re-installing WordPress again? This time, give your primary user a new name. Anything but "admin" will do. Then try the import.

  9. goingnutz
    Posted 3 years ago #

    HI Esmi,
    I installed a completely new WP3.3.1 on another server...imported the xml file from the old/damaged WP3.3.1 site and boom, same issue. i changed the name of the administrator too.
    Im going to have to start a months work all over again, the worrying thing is, if i cant actually identify the problem, the client will lose confidence in WP as a system. Im starting to lose confidence myself. this is a tricky problem encountered by LOTS of people, the forum is riddled with similar issues.

  10. esmi
    Forum Moderator
    Posted 3 years ago #

    This confirms that there is an issue in the imported content itself. Have you checked the server's error logs for clues?

  11. goingnutz
    Posted 3 years ago #

    I agree re content being the issue, but how can content, images/text cause an issue like this? I will check the error logs again...

  12. esmi
    Forum Moderator
    Posted 3 years ago #

    If the old site was (for example) hacked, it's possible that code was inserted directly into the database that could wreck WP.

  13. goingnutz
    Posted 3 years ago #

    im almost 99.99% sure the site hasnt been hacked, its only accessible by 4 people.
    so hacking is ruled out.
    im going to rebuild the entire site today, what has happened has been a major blow to my view of wordpress,..maybe you really do only get what you 'pay' for.

  14. goingnutz
    Posted 3 years ago #

    OK, after rebuilding the entire site and backing it up constantly...
    I came back to the site above this morning, just to try adding the site to https://managewp.com. (Which is an AWESOME site if you want to backup and/or move your site to another server by the way, PLEASE DO NOT FOLLOW THE RUBBISH Steps given on this forum if you want to move a site people...just USE https://managewp.com it works and it takes 5 mins!).
    Anyway, Whilst trying to add the managewp plugin i got a 'Fatal error: Allowed memory size of 33554432 bytes exhausted' message, so i tried
    adding this line to my wp-config.php file:
    define('WP_MEMORY_LIMIT', '64M');

    and hey presto the whole site works again!!!!!!!!!!!!!!!!!
    I cant believe it...over a month of extra work and all it was was MEMORY! i asked GoDaddy about this right at the beginning and they said it wasn't a memory problem.

    There you go people, just add,
    define('WP_MEMORY_LIMIT', '64M');
    to your wp-config.php file and you should be good!

Topic Closed

This topic has been closed to new replies.

About this Topic